SwedeSpeed - Volvo Performance Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
My 2008 V70 3.2 is bucking. It's got 136,000 miles on it. The bucking seems to be between 1st & 2nd and 2nd & 3rd. It also seems to be more prevalent when accelerating through left turns. This issue started about 5,000 miles ago.

I have replaced the fuel pump sensor and spark plugs, and did a transmission flush at ~30k miles ago, at 106k miles.

Any ideas what's next? Throttle body? I do not have VIDA, unfortunately.
 

·
Registered
Joined
·
1,279 Posts
You could try cleaning the throttle body. Be sure that the plastic hose gets reconnected firmly.


2002 V70XC, 2003 V40, 2004 S60, 2010 V70
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #3 ·
Thanks @bigtimemcalpine. Is this something you've done before? Are there any specific instructions to our generation of V70's?
 

·
Registered
Joined
·
1,279 Posts
Well, before I started doing all the work myself, I did have an issue with my throttle body on my V70 2010. I don’t think my symptoms included not starting but I do remember that it was a cheap repair at the dealer...$200. The design/location is a bit strange. You access it from underneath I think. It’s really easy to not reconnect plastic hose properly and maybe that’s what has happened in your case. Not sure if that helps you. Sorry I can’t be of more assistance.


2002 V70XC, 2003 V40, 2004 S60, 2010 V70
 

·
Registered
Joined
·
1,279 Posts
Are you certain that you got the level of fluid exactly right when you did the tranny flush? It is very sensitive to level and it doesn’t take much to be off.


2002 V70XC, 2003 V40, 2004 S60, 2010 V70
 
1 - 6 of 6 Posts
Top