SwedeSpeed - Volvo Performance Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
2012 S60 T5, ~ 60k miles.

So the #3 fuel injector failed, stuck open and the car was driven about 10 miles like this, obviously just washing down #3 with fuel the whole time.

Got it replaced, and car starts and runs MUCH better now (no more white smoke), but we are getting a P2195 code and an occasional misfire.

On my OBD reader, I'm seeing good activity on what's labeled "O2 SENSOR #2" .. idles around .9v and sweeps through the range as expected with acceleration.

However, I get the code mentioned (P2195) and stuck on 0.0v on what's labeled "O2 SENSOR #1" in my reader.

Any thoughts ?


Thank you !
 

·
Registered
Joined
·
722 Posts
Not sure what to say other than to replace the #1 oxygen sensor. At 0.0 volts it's pretty obviously failed and the P1295 code indicates that the #1 oxygen sensor has failed so you've already got two things telling you what part has failed. Make sure that it's plugged in first, then, if it is plugged in and still at 0.0 volts, replace it. It's probably carboned up from all that excess gasoline.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Not sure what to say other than to replace the #1 oxygen sensor. At 0.0 volts it's pretty obviously failed and the P1295 code indicates that the #1 oxygen sensor has failed so you've already got two things telling you what part has failed. Make sure that it's plugged in first, then, if it is plugged in and still at 0.0 volts, replace it. It's probably carboned up from all that excess gasoline.

Right on, thanks for your comments. It's always nice to get a confirmation on a theory :)
 
1 - 4 of 4 Posts
Top