SwedeSpeed - Volvo Performance Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
267 Posts
Discussion Starter #1
alright so i know this topic has been gone over plenty of times but i just want to refine the info a little bit to pinpoint it to my issue.

I have a 06GT R with 138xxx miles, i did a transmission flush sometime 6-7 months ago, replaced timing belt, oil change recently and have not updated the TCM.
iv read the TNN for the valvebody and im not sure if it really applies to me since im not experiencing that sort of clunking, hard/harsh shifting.
so before i go searching for a reman valvebody or basically just live with the issue i just wanted some advice from the pros

with conservative driving, between shifts (automatic mode and not geartronic) from 2-3 sometimes 3-4, the engine seems to stall & car "bucks" in between shifts and wait a couple seconds before it catches to change gears. I don't have the clunk that most people have experienced, although it has happened a few times before, but i replaced my transmission torque mount and everything was good.
it feels like really weak and loose shifts. Not strong and precise.. Iv seen in previous posts something about hydraulic steering being an issue? idk, shoulda bought a MT:facepalm:
 

·
Registered
Joined
·
11,628 Posts
Updating the TCM to the latest software is a must.
 

·
Registered
Joined
·
4,001 Posts
idk, shoulda bought a MT:facepalm:
yeah, you are missing out on all the slave cyl failures :thumbup:, come over to our side. :p We'll even throw in a weaker collar gear.
 

·
Registered
Joined
·
1,491 Posts
Also have the trans fluid tested for contamination with coolant. The trans cooler is built into the radiators, and sometimes they leak causing cross-contamination. Dealer has a test kit for it.....
Caused similar symptoms in my 04.
Also, make sure that the car isnt over-boosting. Caused similar symptoms in wifes 06. Was a faulty IPD TCV. Put in a stock one and its been running fine (knock on wood)
 

·
Registered
Joined
·
267 Posts
Discussion Starter #5
Also have the trans fluid tested for contamination with coolant. The trans cooler is built into the radiators, and sometimes they leak causing cross-contamination. Dealer has a test kit for it.....
Caused similar symptoms in my 04.
Also, make sure that the car isnt over-boosting. Caused similar symptoms in wifes 06. Was a faulty IPD TCV. Put in a stock one and its been running fine (knock on wood)
hmm i know my radiator is definitely leaking...
 
1 - 6 of 6 Posts
Top