SwedeSpeed - Volvo Performance Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I recently bought an '88 780 (yes, it's not a 740 or 760 but I'm hoping someone in this forum will recognize the problem I'm having). Overall it's a great car, although not as reliable probably as the 240's or 740/760's. I've fixed a few of the issues it had when I bought it - the typical melted heater blower fuse, etc.<p>The problem I'm having trouble with is that when I accelerate from a dead stop, there's a grinding/popping noise that lasts for just 1 or 2 seconds as the car starts to accelerate. It's loud enough to feel the vibrations in the seat. It seams to be coming from directly under the center console area where the emergency brake handle is. <p>I can't pinpoint precisely where it's coming from since it only happens when the car is in motion and I can't exactly strap myself to the bottom of the car while it's accelerating. Well...I could, but you know.<p>Any ideas?
 

·
Premium Member
Joined
·
19,953 Posts
Re: Grinding noise when accelerating from a stop (speedyg)

Welcome to Swedespeed, Josh.<p>Is your 780 a 4-cylinder? Automatic?<p>The noise you describe may be a worn driveshaft center support bearing/bushing and/or a worn u-jnt or two or three. Even bad motor/trans mounts can cause this vibration.<p>More details please.<p>George Dill<p>
 

·
Registered
Joined
·
1,368 Posts
Re: Grinding noise when accelerating from a stop (gdill2)

Yes a very good idea there dill. He might also have a combi problem of the driveshaft and a misfire that also would be heard under the handbrake thru floor as the CAT is there and the popping would be a misfire in the CAT once it is hot. Thou not really a common thing in the 2.3 turbo it is a rather common thing in the 2.8 boat anchor V6 with bad or going bad cams. Many times the the unburned fuel form a bad cam/s going right into the exhuast and into the cat where it stays till it gets hot and then gets ignited after the fact. A slight pop or bang/thud is what you might hear form that was well. Under load at the start of accel is when it will do it worse like his might be. Worn chains in the 2.8 only make it worse too as the ign will then wobble at the dist and set up a further slight misfire that also leads to a exhaust born minor sets of explosions. Not sayin it is that . But The 2.8 in the 265 we had, had bad cams and slightly worn chains. And it had a slight booming thumping drive train thing going on till it was fixed for those. Also used alot of gas and oil. Lets hope he has the 4cyl and not the 6cyl. As he is in for a real treat if he bought a 6cyl 780. <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/tongue.gif" BORDER="0">
 
1 - 3 of 3 Posts
Top