SwedeSpeed - Volvo Performance Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter · #1 ·
A minor question, probably aimed more towards XC drivers... have you got a rubber strip located between the front edge of the hood, and attached to the top edge of the grille? <P>On mine, the adhesive was peeling off prior to my last service, and then after that, noticed it had been removed altogether, probably by the service guys. <P>
 

·
Registered
Joined
·
32 Posts
Hello Coastal,<P>I haven't posted recently but have been lurking in the background.<P>Yes, I do have that rubber strip on my XC and I had the exact same problem with it coming loose. I brought it to the attention of my servicing dealer at my first scheduled oil change last week and they have ordered me a new piece. <P>I think your service dept. should replace it, not just remove it and not tell you about it. <P>Regards,<BR>Frank<P> <P>
 

·
Registered
Joined
·
528 Posts
What? You think you guys are special because you have big, bad XC's? <IMG SRC="http://www.swedespeed.com/ubb/smile.gif"><P>All the V70's have that little strip. Even my sissy little T5. I just checked mine (of course) and I can't imagine that thing coming loose. I tugged on it until I thought I'd tear my shoulder out, and it remained affixed to the top of the radiator. I wonder if they ran out of the good glue before they started making the XC's?<P>- Darell
 

·
Registered
Joined
·
226 Posts
Discussion Starter · #4 ·
Actually, <BR>It's probably the same one as the V70. Just figured it might be unique to the XC since our cars are made to go through rivers n stuff. <P>Either way, I'm gonna have them put a new one on. The last thing I need is for my engine to get flooded when driving through the Fraser... yeah... something like that.. <IMG SRC="http://www.swedespeed.com/ubb/biggrin.gif"><P>
 

·
Registered
Joined
·
528 Posts
Don't forget the add the snorkel air-intake while the XC is in getting it's new submarine hood seal. Might want to check the wipers too.<P>- Darell
 

·
Registered
Joined
·
47 Posts
Coastal,<P>I've been slacking. I forgot about this thread (and it has been raining terribly until today so that may have something to do with it). I just went out and checked my strip. It's there and securely attached. I can't say if it's the original though, because I hadn't paid attention to it before.<P>--Adam
 

·
Registered
Joined
·
226 Posts
Discussion Starter · #7 ·
Hey,<P>Just spoke with the service guy. They went ahead and ordered a new one when the car went in a couple weeks ago.. I didn't know this, it's all good <IMG SRC="http://www.swedespeed.com/ubb/smile.gif"><P>
 
1 - 7 of 7 Posts
Top