SwedeSpeed - Volvo Performance Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
369 Posts
Discussion Starter · #1 ·
Been there ever since I did the ipd intake and boostability kit.. But because the cars been parked for the winter... Didn't think about it...
Thoughts? Is this the bad noise?

https://youtu.be/oXICcdMAzMk



Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
6,562 Posts
Bad sound. Sounds like compressor surge. Maybe the diverter isn’t opening when you lift.
 

·
Registered
Joined
·
104 Posts
I ran into this issue and found that there was a little plug not fully seated and was throwing the caR for a loop.

Sent from my Pixel 3 using Tapatalk
 

·
Registered
Joined
·
369 Posts
Discussion Starter · #4 ·
Thanks this is what I thought... I'll play with the tension on the valve...

Thx

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
67 Posts
Sounds almost like a turbo that the bypass valve isn't working correctly on, sounds basically like a normal turbo car when they dont have a blow off valve, the air surges back against the turbo wheel and causes that fluttering sound. Not usually a bad thing but it is on volvos since they are supposed to recirculate. I'd check the bypass valve

Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
369 Posts
Discussion Starter · #6 ·
Ok.. So was totally compressor surge.

I backed out the adjuster on the diverter completely as an a/b test... And it went away.

I'm on the Dyno tomorrow for a baseline test of hp before tuning starts. So I'll watch to see boost and if the diverter is now leaking boost.. And adjust from there.

Thx all

Sent from my Pixel 3 XL using Tapatalk
 
1 - 6 of 6 Posts
Top