SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 32 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter · #1 ·
Hi guys, another old '66 1800 volvo thread.

Today, for the first time, my car started dying at high speeds; a fuel problem. Car turns over and starts (after a few cranks to fill the bowls I assume) immediately after dying. I've driven it in hotter weather, and for longer periods, so I don't think it's a vaporlock issue, unless something could spontaneously cause that. It also starts right away hot so it's unlikely.

Is it possible that the fuel pump has worn, or come loose in a way that would diminish fuel pressure? I haven't had a chance to put a gauge on it (took me 2 hours to drive ~ 5 miles home, 1 bowl of fuel at a time)

It idles ok. Any acceleration and it quickly runs out of steam and stalls if I don't stop and drop it back to idle.

It's not related so much to RPM (can rev up to redline for a short period of time) and the spark system was recently gone over. I think the generator may need new brushes, or overhaul since the blinkers don't want to work anymore. Never had a problem with starting, although I haven't taken a meter to the battery in a few weeks to see if it's putting out an appropriate charging current.

In the morning when I try to start it up (or later tonight if need be) I can get the cold start symptoms and see if it's a hot only thing. It needs a fuel filter, as the recently cleaned bowls have developed a significant amount of sediment in the bottom. I'm pretty sure it's not a blockage in the carbs or fuel passageways due to it's intermittent yet consistent appearance.

HELP!
 

·
Registered
Joined
·
77 Posts
at idle the car will be drawing less fuel than the car will need at higher rmp, you say there is a lot of stuff building up in the bowl, you may have a fuel supply issue.

If the tank is empty take the bolt out of the bottom, clean all the undercoating off first so you don't strip it.

Inside there is a small sock filter that may be plugged with debris.

New filter available here:


http://212.247.61.152/eu/main.aspx?page=article&artno=688593

Also replace the inline fuel filter, I used a clear glass one so I could visually inspect.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #4 ·
at idle the car will be drawing less fuel than the car will need at higher rmp, you say there is a lot of stuff building up in the bowl, you may have a fuel supply issue.

If the tank is empty take the bolt out of the bottom, clean all the undercoating off first so you don't strip it.

Inside there is a small sock filter that may be plugged with debris.

New filter available here:


http://212.247.61.152/eu/main.aspx?page=article&artno=688593

Also replace the inline fuel filter, I used a clear glass one so I could visually inspect.
I was thinking there could be some small obstruction in the line somewhere, not a full blockage but a partial one.

Is it possible for the pump to gradually fail, or is it a on one off the next kind of failure? I'd rather not pull it off if I don't have to.

Crud in the floats is a fine rust looking substance. Finer than table salt, no big flakes.

Tank is full. I'm not going to be dropping it, so assuming the tank is full of rusty grit (probable after almost 50 years) is there any way to clean it on car? If not I guess I'm not wholly opposed to taking it off and cleaning it with acetone and a chain, but I'm not to the point where I'd send it off to a rad shop to be dipped.
 

·
Registered
Joined
·
1,334 Posts
I have a similar problem to my 68 B20. Only milder than yours. I was suspecting the fuel pump getting weak. So, I had tried an acceleration, and when the engine started missing, I tried to turn off the engine and check the float bowls and see if they were low on fuel. They were not (you can try that, easier than installing a fuel pressure gage and routing it behind the dash).

My problems were/are crud from the tank reaching the carburetor. Then, they temperarily clog up the jets. When you slow down to idle, they settle to the bottom of the bowl, and the carb works fine for a while. It is relatively easy to remove the whole bowl assembly, along with the little flex line that supplies fuel at the bottom of the jet. Just remove that 7/16 head size screw that holds the fuel bowl, and the tiny screw that holds the choke cable (in the reverse order). Then, wash the bowl and fuel line with hot water. That will temporarily reduce the problem (that is, if the fuel pump is healthy, which it probably is).

I have two fuel filters on this B20 (both down stream the pump, up stream the pump is no place for a fuel filter), and still some crud get through. When I drive the car hard in corners, the problem is worse (see my thread "some fun driving" in the Amazon page!).

D
 

·
Registered
Joined
·
1,393 Posts
Upstream from the fuel pump WILL help keep the grit from fouling the fuel pump check valves and making the pump inefficient or nonfunctional.
If your fuel pump cannot suck through a small filter, you should replace it.
 

·
Registered
Joined
·
1,334 Posts
Warlus, I could really feel the suction on that fuel pump even at low rpm. So, the pump must be good. However, with a filter up-stream, the car could not even hold up to 50-55 mph. I don't think the grit can really hurt those check valves too much. Worse case they may not seal too well over a stroke or two. But I doubt it can do permanent damage. Generally speaking, it is a bad idea to install fuel filter upstream any positive displacement pump. Especially if the fluid pumping is volatile.
 

·
Registered
Joined
·
1,334 Posts
This is different. They are working on a P1800 ES, which is fuel injection. I had to go through that recently. These gas tanks have a huge plug, which allows you to access the sock. Your car has a tiny 1/4-NPT plug in the gas tank, allowing you only to drain the fuel. Also, in the P1800ES, the fuel pump circulates a huge amount of fuel, so it would be much more sensitive in the restriction of the sock. If the fuel pressure on the ES drops below 30 psi, it starts missfiring due to lean operation at all loads, and the pump circulation is also the same, regardless the load (unlike the cars with carburetors). Your situation is different. Your missfire is caused by dirt clogging up the carburetor jets.

But if you want to make sure, just install a pressure gauge downstream the pump. My guess is that you will have your 2-2.5 psi at all times, regardless how much you rev it.
 

·
Registered
Joined
·
1,393 Posts
Dmitri,
For reasons not clear to me your experience is different from mine. The ONLY time I have had a problem with a filter upstream of the pump was when it was full of dirt/rust/water. I have been running filters both upstream and downstream of fuel pumps, both diaphragm and electric for over 40 years with no trace of the problem you cite. However I HAVE had fine particulates foul both valves in diaphragm fuel pumps to the point that they would neither suck nor exhaust on numerous occasions. That is why I put them upstream. It solves the problem I have had. BTW it also provides a visual check on fuel contamination (translucent plastic filters). For example when I first fired up the 1800 that went to Kent, it started right up and then the fuel filter turned black and it died. Turned out there was water with suspended magnetite and other anaerobic corrosion products in the tank. It was really good to be able to see what it was BEFORE it got into the pump.

General suggestion: Don't discount others' experience. They may have more than you.
 

·
Registered
Joined
·
1,334 Posts
The 440 does not like the up-stream fuel filter either.

I think that modern fuels may be more volatile than they used to be, and the up stream fuel filter is less of a good idea now that it may have been in the past ... Who knows.
 

·
Registered
Joined
·
77 Posts
I may not be understanding the issue with the upstream filter. To my knowledge concerns with addition of a upstream filter come from the potential for fuel leak, fire and fuel gravity feeding to the fire. Most manufacturers now require cars to have upstream filters to prevent debris from damaging the pump and in some systems there are pre and post filters designed into the system.
Key note here - you must match the volume of the filter to the volume of the pump, you can even select different filter elements so a pre filter could capture large sediment only.

Anyway, did you find anything in the tank with the magnet?
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #14 ·
I may not be understanding the issue with the upstream filter. To my knowledge concerns with addition of a upstream filter come from the potential for fuel leak, fire and fuel gravity feeding to the fire. Most manufacturers now require cars to have upstream filters to prevent debris from damaging the pump and in some systems there are pre and post filters designed into the system.
Key note here - you must match the volume of the filter to the volume of the pump, you can even select different filter elements so a pre filter could capture large sediment only.

Anyway, did you find anything in the tank with the magnet?
Didn't get to actually tear anything down today. Car's parked at my apartment, about 15 minutes from my shop. Roads are busy during the day and I can only drive about .5 km before needing to stop so I'm thinking I'm going to move it to the shop tonight.

Crawled around under the car. Fuel tank has a large (1.5" maybe?) plug on the very bottom. Put in that plug is a regular allen head bolt...I'm thinking someone may have drilled it out in the past and added that?

The pickup goes in on the front, around 5" up from the bottom of the tank. No large plug to remove. Do I need to go in through the sending unit hole to get to the sock filter?
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #15 ·
Didn't get to actually tear anything down today. Car's parked at my apartment, about 15 minutes from my shop. Roads are busy during the day and I can only drive about .5 km before needing to stop so I'm thinking I'm going to move it to the shop tonight.

Crawled around under the car. Fuel tank has a large (1.5" maybe?) plug on the very bottom. Put in that plug is a regular allen head bolt...I'm thinking someone may have drilled it out in the past and added that?

The pickup goes in on the front, around 5" up from the bottom of the tank. No large plug to remove. Do I need to go in through the sending unit hole to get to the sock filter?
Forgot to add, haven't put a magnet in yet, don't have a donut one I can tie a string to at the moment.
 

·
Registered
Joined
·
1,393 Posts
With a steel tank it may be kinda hard to do much with a magnet in the tank. If it does have a sock filter it will have a BIG plug in the bottom with a square socket in it which you unscrew to pull the unit out. (Do this with the tank EMPTY!!) BTW I DO have a prefilter between the tank and the pump on both my 73 145E and my 72 164E. Both have saved me a great deal of grief. In fact I am still changing filters since getting the 164E going, I'm on the 4th one now. Time between changes is getting longer.
 

·
Registered
Joined
·
1,334 Posts
I guess I had assumed that cars with carburetors have similar fuel tanks to the Amazons, and the large plug is only on the fuel injected cars. That plug required a square ratchet a bit smaller than 1/2", so it must have been metric. We made one by grinding an old 0.5" ratchet to an "approximate" fit.

But before you go to the trouble of dealing with the gas tank, try to make sure that your fuel pump really provides or not the proper fuel pressure. This is a lot easier than draining the tank and reaching for that sock filter.

In the filter location discussion, I think we need to remember if we are talking about a carburated car or a fuel injected car. The fuel pumps of carburated cars are a lot more robust. The main issue I have had with filters up stream the pump is cavitation. Even a small restriction on the inlet, with as bad as modern fuels are, can cause cavitation. The worse time for the problem is on a warm winter day. You have high volatility gasoline combined with warm weather (we can have winter days here in Texas warmer than many summer days in other parts of the country).
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #18 ·
If its a carbeurated car the clear plastic inline filters should be fine. The higher pressure FI cars should use a high capacity inline filter like Walton and a plethora of other companies use. The same amount of horsepower takes the same amount of gas, but the HP FI system has a return line...
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #19 ·
Picked up some bits to check the volvo out...

Got (2) Fram G1 fuel filters. I don't particularly like FRAM as much as I like MANN or other high end filters, but this was the largest inline clear filter I could find with 1/4" inlets and outlets. Construction looks good with thick plastic and metal capped filter body. I suppose I'll try it with one on the carb side of the fuel pump, and one between the tank and the chassis hard line, as long as I can get it high enough that I feel road debris won't be a problem.

Got (2) 20l jerry cans for a steal (5 bucks a piece on sale) so I can drain the tank if need be.

Permatex form-a-gasket, fuel safe stuff for the plugs if I have to remove them

Fuel pressure tester. The tester isn't the (in-out) kind, it just has an (in) so I'll have to rig up a tee to be able to check the pressure while running. If it's in fact a plugged up sock filter in the tank (still unsure of how that one is accessed as well as its size) would that throw off the fuel pressure on the high side of the pump, leading to misinformed diagnostics? Would just cranking the engine with the fuel line straight into the pressure gauge (no supply to carbs) be a definitive enough test? If it's a fuel delivery problem that means pressure is down, and that I essentially have to go through the system from the tank forward, right?
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #20 ·
So,

I installed the fuel filter, new lines forward of the hard line, and blew air (lung pressure, yum!) backwards down the steel chassis line. It felt somewhat like an obstruction was there (high initial pressure, but then bubbles) but that could have just been the "water column" of fuel I had to displace from the line.

Took the car around the block, no stalls, no quits.

The inline filter isn't filling entirely with fuel, there's airspace in it. What's causing this? When I went to take the fuel line off of the carb floats to check the fuel level in the bowls it sprayed fuel as if there was quite a bit of pent up pressure. This is caused by the airspace, I reckon, but how do I get rid of the airspace? Is it caused by the unvented fuel tank? Should I preload the filter with fuel? The car ran for a good 30 minutes and it kept the air, so I don't know how to fix it, other than maybe taking the line off, cranking the car with the coil off and trying to fill the filter that way... Maybe I just solved my own problem...

In any case I think I can now easily drive the car to my shop to address the tank issue. I have a strong feeling it's full of rust and flakey goodness, but we'll see.

Added to the complication of this my beater (88 K car) had it's tilt column explode, rendering the car entirely unsteerable. Luckily I found a non tilt column at a wrecker (175 bones, talked down from 250....) to replace it with so it's now operational again....

Onward!
 
1 - 20 of 32 Posts
Top