SwedeSpeed - Volvo Performance Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
05 S40 T5 135K miles.

Fuel gauge kinda just picks and chooses when it wants to be right, more recently having some tougher starts on steep inclines, with occasional rough starts on flat surfaces. Doing a standard tune-up today but....

I'm wondering if the gauge is a PEM issue or a fuel pump issue and if anyone could point me to the specific location for both (links to videos/pictures/forum discussion would be great). My understanding is the PEM might be under one of the rear seats? And the pump is likely a whole assembly (filter and all) under/near the tank? I've looked through the forum, but answers seem a bit everywhere.

I don't think either has been replaced, but this is my daily commuter so I'd like to keep him going by replacing them preemptively.

Thanks for your help! 😊
-Beau
 

·
Registered
Joined
·
1,235 Posts
Hi
Pump&sender unit are all in one and are in the fuel tank itself. On this model you cant get them trough rear seats, like on prev generation - you need to take fuel tank out for any fuel-pump related issues (easier on your FWD than on mine but still a pain in the rear). How much differences between actual level and indicated level you experience? Our cars kinda "estimate" what is the fuel level in tank, its based on some algorithm of how you drive vs calculated mpg vs level from the sensor, it happened to me few times when low on fuel that it went to zero and then back to 1/4 tank when I was idling on traffic lights.
 
1 - 2 of 2 Posts
Top