SwedeSpeed - Volvo Performance Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
2,202 Posts
Discussion Starter · #1 ·
On the way to work this morning I noticed my fuel gauge drop to empty and the message center dropped off to —— miles to empty. The low fuel light never came on. When I cycled the car off and back on it was ok. On the way home it was no problem but showing about half tank. I had already traveled about 290 miles so I thought that wasn’t right so I stopped to fill it it. Had to put 16 gallons in. Anyone have a clue? Will get ZZZZZZZ’s to scan with his VIDA sometime soon.



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
543 Posts
Could possibly be the level sensors. You’re on the right track having zzzzzzz scan her with Vida.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,202 Posts
Discussion Starter · #6 ·
DAMN! I don't feel like going into the fuel tank. Maybe I will wait for complete failure.
 

·
Registered
Joined
·
6,606 Posts
Just fill it every 300 miles like I do... regardless of what the sensor says. Also be aware that range left and fuel gauge position are based on fuel consumption... not 100% based on level.
 

·
Registered
Joined
·
3,491 Posts
Well if I have to go in there then I might as well upgrade the pump lol

Sent from my ZTE A2017U using Tapatalk
If I remember correctly there are 2 sensors inside the tank. One is on fuel pump, another one - at the opposite side. So better check the VIDA as you might not need to open your pump side opening...
 

·
Registered
Joined
·
2,202 Posts
Discussion Starter · #9 ·
Just fill it every 300 miles like I do... regardless of what the sensor says. Also be aware that range left and fuel gauge position are based on fuel consumption... not 100% based on level.
Thats pretty much what I was planning. I am not messing with it unless it fails and I think I might sell the caR. When that happens I will fix.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
17,424 Posts
Anyone point us to the correct part of VIDA to get those readings?
I'm sure I can stumble through, but sometimes knowing a little to narrow it down ahead of the time spent can help.
TIA
 

·
Registered
Joined
·
543 Posts
I’d have to go into Vida to be completely sure but I believe its in the cem section.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6,606 Posts
In the CEM or REM. Unless the PEM has a list of readouts. Don’t think it’s in ECM.
 

·
Registered
Joined
·
704 Posts
My aftermarket sender crapped out showing no fuel and -- miles to empty but it only throws a CEL occasionally. I forgot which module VIDA points to.
 

·
Registered
Joined
·
2,219 Posts
Theres a cem software upgrade for fuel gauge intermittantly drops to zero. I think it applies to 05 on.
What? Is there a write-up do this cem voodoo?


Sent from my iPhone using Tapatalk
 
1 - 16 of 16 Posts
Top