SwedeSpeed - Volvo Performance Forum banner

1 - 8 of 8 Posts
G

·
Discussion Starter · #1 ·
Anyone know how to replace the fuel filter on a 2010 3.2l awd? Is there a write up somewhere that I’m missing?

My gut tells me it’s in the tank and not “user serviceable”


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
16,847 Posts
Not listed anywhere. Not even FCP, so must be. Problems?
 
G

·
Discussion Starter · #4 ·
Not listed anywhere. Not even FCP, so must be. Problems?
That’s what I’m suspecting. I managed to order one from rockauto (Mann brand) but it has a ground tab on it for electrical../

Had a lean code pop up the other day and stick around for a few. That coupled with 97k miles and I’m due for stage 0...


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
5,010 Posts
There is no external filter.
Is there an access panel to the tank or do I actually have to drop the tank if I wanted to replace it?


Sent from my iPhone using Tapatalk
No access panel, the tank comes down to replace the pump.

Aside from a rusted filter leaking, I've never repaired a problem by replacing a fuel filter. I doubt the pickup screen is your problem. Most common cause of a P0171 on your car is a PCV breather box.
 
G

·
Discussion Starter · #7 · (Edited)
No access panel, the tank comes down to replace the pump.

Aside from a rusted filter leaking, I've never repaired a problem by replacing a fuel filter. I doubt the pickup screen is your problem. Most common cause of a P0171 on your car is a PCV breather box.
Well F me, that’s $12 wasted lol. The lien code cleared up on its own after I put premium in the car and filled it up. So I’m wondering if maybe I got a bad batch of gas instead. I have noticed however that I am having difficulty filling the tank and it’s acting like a J hose problem on the P 80 and P2 cars but without the fuel smell...not venting? Figured at the mileage too it wouldn’t hurt as preventative maintenance


Doing plugs and other filters this weekend, and think I have a spare fpr around. It feels like it has a hard stumble on acceleration


FWIW the filter I bought was the Mann WK6004 from RA
Sent from my iPhone using Tapatalk
 
G

·
Discussion Starter · #8 ·
Plugs and air filter in over lunch break today at work... ngk ruthenium plugs replaced original FoMoCo plugs with 97k. Ashy as F...

Found mouse nest in the lower air box....


Sent from my iPhone using Tapatalk
 
1 - 8 of 8 Posts
Top