SwedeSpeed - Volvo Performance Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
445 Posts
Discussion Starter · #1 ·
fuel filler cap open loose

checked my cap and the seal looks brand new and it closes like it should, what could it be

thanks !
 

·
Registered
Joined
·
8,055 Posts
EVAP system has found a big leak and is assuming its the cap most likely. Bad news is that if the gas cap is good you have a leak somewhere else in the fuel system. The R is known to have some issue with the seals on the access ports to the fuel tank so my advice would be to check them out. Have you noticed a gas smell around your car, especially right after its been filled up?
 

·
Registered
Joined
·
445 Posts
Discussion Starter · #3 ·
EVAP system has found a big leak and is assuming its the cap most likely. Bad news is that if the gas cap is good you have a leak somewhere else in the fuel system. The R is known to have some issue with the seals on the access ports to the fuel tank so my advice would be to check them out. Have you noticed a gas smell around your car, especially right after its been filled up?
I see, I didn't notice a really strong gas smell around the car. Where exactly do I check for those seals on the access ports, where are they located.

Also want to mention that the message comes on a off from time to time, its not the first time I see it and it popped again a week later today.

Is it dangerous, I mean if I use lighters in my car and etc.

ty stealthy
 

·
Registered
Joined
·
423 Posts
I see, I didn't notice a really strong gas smell around the car. Where exactly do I check for those seals on the access ports, where are they located.

Also want to mention that the message comes on a off from time to time, its not the first time I see it and it popped again a week later today.

Is it dangerous, I mean if I use lighters in my car and etc.

ty stealthy
Had the same problem. Swapped a new gas cap in, problem solved. :)
 

·
Registered
Joined
·
234 Posts
How could the seal / Oring be like new on the cap ? It's ten years old . It may have cracks , I personally would put a new one on first . This has happened even if the cap was not turned tight to 3 clicks on my o2 v70 , replaced Oring no more problem
 

·
Registered
Joined
·
955 Posts
Start with the basics, get a NEW OEM Gas cap. Had this issues with mine this summer, gas cap solved the issue.

And BTW my gas cap looked brand new too...
 

·
Registered
Joined
·
1,377 Posts
Funny how I read this and I got the same message for a few minutes then it went away. Not I just have a CEL I have to get read and cleared but I'm pretty sure it's fuel cap related. It also just started happening after my last fill up where I dropped the cap....
 

·
Registered
Joined
·
445 Posts
Discussion Starter · #10 ·
The message did not come back on for a few days now, pretty confusing, going to let as is until it starts to pop more often.
 

·
Registered
Joined
·
575 Posts
I had the same issue on a 2.5t S60. Intermittent just like you describe. It would come on after long drives up the northeast, so maybe the change in temperature would cause pressure changes? Unsure. Either way the O-ring replacement worked and the code never came back.
 

·
Registered
Joined
·
50 Posts
Just to throw my two cents in, I found a similar issue with my XC70, but even after replacing the gas cap it only made a difference for a few months. It turns out that there is a rubber hose that connects two pieces of hard plastic line for the evap system together. The hose was leaking and then completely popped off. I believe this is outside on the passenger side floorboard just behind the subframe. I put mine back together and zip tied the connection. Problem solved... for me.
 

·
Registered
Joined
·
955 Posts
This post is dead, get a gas cap!!!
 

·
Registered
Joined
·
1,377 Posts
It's arriving Thursday from FCP. Cleared the code. Message pops up for a few minutes then goes away. Turn the car off then back on and I have a CEL. Really hope it's the cap!
 
1 - 15 of 15 Posts
Top