SwedeSpeed - Volvo Performance Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,065 Posts
Discussion Starter #1
Alright, so this might be the source of my clunking and harsh ride.

Now... WTF do I do to fix it?

Taken a couple months ago, large gap, bouncing the car resulted in a clunk:



Taken last evening, normal gap?, bouncing the car resulted in no clunking at all (car still clunks during driving over bumpy surfaces though):



This started happening some time after I had my indie mechanic install new front struts, along with HD spring seats from iPd.
 

·
Registered
Joined
·
944 Posts
the gap is normal, it will increase/decrease as you turn the steering wheel. Check/tighten sway bar links. They are probably number one wear item in the suspension.
 

·
Registered
Joined
·
3,758 Posts
sure the clunk is coming from the stuts itself? could be endlinks, sway bar or any number of other front end components
 

·
Registered
Joined
·
1,065 Posts
Discussion Starter #4
Hmm. I replaced my endlinks about this same time last year with new OEM. That got rid of a rattling noise, as opposed to this occasional 'clunk' that also seems to be associated with the front end being skittish as all hell and the ride being fairly rough over somewhat minor bumps (hard initial 'bang').

I also had my mechanic check out the front end for any issues like bad bushings after this problem initially showed up and he couldn't find anything out of the ordinary.

I suppose if what I posted as a problem is normal movement (I can't remember the steering angle when I took the first picture) it could be that it only clunks when I bounce it when the wheels are turned. I'll have to check that out...
 

·
Registered
Joined
·
3,758 Posts
did you do a sum recal after the install of the new struts?
 

·
Registered
Joined
·
1,065 Posts
Discussion Starter #6
did you do a sum recal after the install of the new struts?
Yes, I have my own DICE unit.

I didn't notice anything wrong until at least a few weeks after the strut install, probably longer. The ride twitchiness seems to have progressively gotten worse.
 

·
Registered
Joined
·
3,758 Posts
Yes, I have my own DICE unit.

I didn't notice anything wrong until at least a few weeks after the strut install, probably longer. The ride twitchiness seems to have progressively gotten worse.
weird man. hope you find out whats wrong.
 

·
Registered
Joined
·
11,628 Posts
I'm betting its your spring seats that are toast.
 

·
Registered
Joined
·
944 Posts

·
Registered
Joined
·
11,628 Posts
he said he got new hd spring seats recently. I'd still check the endlinks if they are tightened enough.
Oops, I see that now. Hmmm possibly the seats are defective or buggered up because its sounds like classic spring seat failure.
 
1 - 10 of 10 Posts
Top