SwedeSpeed - Volvo Performance Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
804 Posts
Discussion Starter · #1 ·
Hi All,
So I installed an aftermarket backup camera over the weekend. It works well and ran the wires as suggested from another volvo forum member, actually I think he's here too, from the UK with the Diesel. The hardest part was running wires and hiding them. I did notice one issue now though; my FM signal has degraded a large amount. I'm noticing that the stations are not coming in clear at all. I've moved the ground wire to different locations but I still have signal problems. Not sure if they are related but the monitor also shows, very lightly, lines going across the screen.

Any thoughts? I'm thinking it has something to do with the wires being run up and down the trunk/rear of the xc90. I can't imagine that I did anything to actually tamper with any antenna.

Thanks!
 

·
Registered
Joined
·
63 Posts
Disconnect the feed wire from the new rear cam, check to see if FM any better. If not disconnect the ground and try again (leave feed disconnected).

Is this cam wired to an OE sat nav on the dash?

If not and your using a separate screen, disconnect the feed and ground as above. The idea is to prove if the fault is with the new unit(s) or the car's OE supply.

I bought a DAB radio some time back, worked great. Then installed a dash cam up by the rear view mirror. Discovered the dash cam doesn't play nicely with the DAB aerial, so it's a case of dash cam or DAB. Dashcam won and DAB is used for USB drive :)
 

·
Registered
Joined
·
804 Posts
Discussion Starter · #3 ·
Disconnect the feed wire from the new rear cam, check to see if FM any better. If not disconnect the ground and try again (leave feed disconnected).

Is this cam wired to an OE sat nav on the dash?

If not and your using a separate screen, disconnect the feed and ground as above. The idea is to prove if the fault is with the new unit(s) or the car's OE supply.

I bought a DAB radio some time back, worked great. Then installed a dash cam up by the rear view mirror. Discovered the dash cam doesn't play nicely with the DAB aerial, so it's a case of dash cam or DAB. Dashcam won and DAB is used for USB drive :)

Thanks Preload....I've moved the Ground Wire to a new location but the FM signal is still bad. I've even tried to change locations of the Fuse Tap. I'll have to find some time this weekend and see if I can tinker with the Red wire some more versus the ground wire. I find it weird that it would be the RED (live) wire because that's tapped from the reverse signal live wire which should only interfere with my FM signal if it's in use correct (while in reverse)?
 

·
Registered
Joined
·
804 Posts
Discussion Starter · #4 ·
So i moved the ground wire again and also moved the live wire around. It doesn't seem to matter where or what i connect it too, the FM signal still degraded. The fuse tap gave me the worst interference. I ended up connecting both camera and monitor to each of the reverse lights. I only get signal problems when the car is in reverse which I can deal with now. I'm not sure if changing cameras will make the issue go away but I'm happy enough with the results.
 
1 - 4 of 4 Posts
Top