SwedeSpeed - Volvo Performance Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3,952 Posts
Discussion Starter · #1 ·
Just wondering how (un)normal this is. I've got the bsr stage 3 , typhoon , bell IC.. and this doesn't happen often , but it did a few months ago as well as today. It only flashed twice, (3x and it stays on) but last time it said "misfire" so I'm guessing it was the same thing today.

note, I've had the bsr stage 3 , going on 3 yrs now and this never happened until then last year , I added the Bell IC and IPDs Iridium plugs ..

am I running lean sometimes or something? This is only the 3rd time in the past year (or ever ) that this happened and everytime under hard acceleration. (I accelerate hard often so it isn't like this happens whenever I mash the gas )

what do you think? Should I run larger injectors... would this eliminate the Flashing CEL for good?
 

·
Premium Member
Joined
·
9,303 Posts
Re: Flashing CEL under hard acceleration? (V50_T5)

Flashing CEL means a miss is being detected. If it persists under normal driving the CEL will light steadily. It has stored a code though, you could pull codes to find which cylinder or cylinders are missing.

Most common cause is bad gas, especially water contaminated. But a weak plug, a schmutzy injector, poor mixture, etc can all cause it too. Try a bottle of isopropyl dry gas and a fill-up at a high-volume brand-name station first. Be sure to use isopropyl, cheaper methanol-based will attack fuel system stuff.

Tom.
 
1 - 3 of 3 Posts
Top