SwedeSpeed - Volvo Performance Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Just bought an 850 and am quite excited about it. I look forward to eating Ramen noodles until I pay it off. <IMG SRC="http://www.swedespeed.com/ubb/smile.gif"><P>When the ignition is on, the horn blows continually. When the ignition is off, so too is the horn off. I haven't had a chance to see if the horn still works from the wheel with the ignition off. Any ideas? I'm hoping there's a known issue for this.<P>Also, the cruise control only works for about 30 seconds before going totally dead. The only way to get another 30 seconds out of it is to reboot the car (turn it off/on).<P>Thanks everybody.
 

·
Premium Member
Joined
·
398 Posts
make sure your computer cartriges are fully in. 3 of them on r/h side.some one has probly played around with the wires behind dash, and replaced them in the wrong spots.<P>michael.<P>
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
I played with the cruise control some more on the way to work today. It held 75 mph with the A/C off for several minutes (all I have on the way to work). The other day when it wasn't working properly we were doing 90 mph with the A/C on. Does the Volvo cruise have a "give up in pain" feature where it just shuts down if it can't hold the requested speed at 3/4 throttle? I know some others do that sort of thing. Does 90mph with A/C seem excessive for an N/A 850?
 

·
Registered
Joined
·
136 Posts
Though I don't usually use the cruise control on the UK's crowded roads, I did on the way to a Volvo event last weekend.<P>I set it to 95 with the A/C on and it worked fine, so there's no reason why yours shouldn't do the same.
 
1 - 4 of 4 Posts
Top