SwedeSpeed - Volvo Performance Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
387 Posts
Discussion Starter · #1 ·
About a year ago I took my car to a shop and had the A/C clutch replaced and my A/C worked fine for a short period of time. I was lazy and didn't pursue it till a week ago. I ordered a new compressor, switch and condenser. Well guess which part was bad.


Old A/C compressor
<a href="http://s22.photobucket.com/albums/b344/rsxer63/?action=view&current=oldACcompressor.jpg" target="_blank"><img src="http://i22.photobucket.com/albums/b344/rsxer63/oldACcompressor.jpg" border="0" alt="Photobucket"></a>

New A/C compressor
<a href="http://s22.photobucket.com/albums/b344/rsxer63/?action=view&current=newACcompressor.jpg" target="_blank"><img src="http://i22.photobucket.com/albums/b344/rsxer63/newACcompressor.jpg" border="0" alt="Photobucket"></a>

Anyone ever heard of this happening?
 

·
Registered
Joined
·
1,511 Posts
Looks like some parts of missing. Glad your A/C is working fine now.
 

·
Registered
Joined
·
387 Posts
Discussion Starter · #3 ·
Yeah, I can't believe that the parts fell off... which they must have or it never would have worked to start with.
 

·
Registered
Joined
·
955 Posts
Good work, I bet the clutch is out there laying on the side of the highway..

I bet it feels great to have that 60 degree cabin again
 

·
Registered
Joined
·
387 Posts
Discussion Starter · #8 ·
We were doing a brake job the other day... When we found the clutch wedged in the frame under neath the passengers side axle!
 
1 - 10 of 10 Posts
Top