SwedeSpeed - Volvo Performance Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
After my freak accident with a sofa flying into my S60, I finally got it back after 15 weeks. Total repair cost was over $11,000, glad I'm not paying it. Some of you may remember it, I posted info on it after it happened.<P>The new sunroof makes a click sound when I pop it up. When I slide it back, it also made a click sound. Any idea what it is? The shop guy couldn't figure it out yet.<BR>There is a message that says "Bulb Failure Position Light". I checked all the lights and everything is working. It comes on once in a while, not all the time, then it goes away. Then there's the CD & tape deck, they don't work. When I turn the source knob, it only goes to FM & AM. Help Please. I'm so pissed, I knew the car would never be the same after an accident like that, and sure enough, I'm right. But at least it's a lease, I can give it back when the lease is over.
 

·
Registered
Joined
·
23 Posts
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by SN60:<BR><B>There is a message that says "Bulb Failure Position Light". I checked all the lights and everything is working. It comes on once in a while, not all the time, then it goes away.</B><HR></BLOCKQUOTE><P>Maybe the light of the license plate or one light is not seated correctly in the rear (are all 4 bulbs burning?)<P> <BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR><B> Then there's the CD & tape deck, they don't work. When I turn the source knob, it only goes to FM & AM.</B><HR></BLOCKQUOTE><P>Could be missing software or loose plug. Take it do a dealership and let them check with VADIS.<P>Hans
 
1 - 3 of 3 Posts
Top