SwedeSpeed - Volvo Performance Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hello everybody.
After getting some help from George and RearWheelPaul reading the fault codes, I read off the following.
2-3-2 Self-Adjusting Lambda sond not operation
1-2-1 Signal to/from air mass is faulty
1-1-3 Fault in Injector (break in lead, clogged etc)

Now the air mass meter I understand, cause it ain't there anymore , the lambda sond fault puzzles me, and finally the injector fault seems odd since the lady I bought the car from 2 month ago had them replaced (maybe not by a Volvo shop, don't know).
However, the lambda sond fault, any one knows what needs to be done there, sooner or later ? I can have injectors checked by a garage I suppose since just wiggling them around ain't doing much of anything......at any rate, hopefully someone has gone through this before and have some ideas...

Thanks for the invaluable help !

Anders
 

·
Registered
Joined
·
785 Posts
Re: Fault codes, 2-3-2 for a 240 (anders57)

Repeat 113 codes could be caused by corrosion of a splice in the injector harness. If memory serves correct (going back a few years here), carefully open up the injector harness and you should find a soldered or crimped splice in the harness near the back of the head. It should be separately wrapped in electrical tape. Open it up and using soldering paste and a hot soldering iron, heat the splice until the solder flows. Add solder if needed.
Also check for any corroded grounds, could be a ground fault voltage drop.

Good luck.
 
1 - 2 of 2 Posts
Top