SwedeSpeed - Volvo Performance Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi I am new to this forum and am having a problem with my xc I hope you all can shed some light. <p>I recently bought a 2000 xc with 68k and have found the wagon to seem to drive and shift normally around town as long as you down need any passing power or accleration. <p>I actually clocked 0-60mph at 13-14 sec which according to stock is about 5 seconds too slow and it feels that way. <p>There is no weird engine noise, whine, smells or smoke coming out but I also cant feel if the turbo ever kicks in. The acceleration g's feel constant. <p>There is a vibration/humming/buzzing noise coming frm the tranny tunnel on center floor in the front only at high rpms when I am flooring the gas pedal.<p>The wagon is in what looks to be perfect condition and everything original.<p>What has happened so far:<p>Volvo dealer in Minneapolis checked it and said;<br> 1-angle/bevel gear is shot and needs replaced $2200 (why its slow??)<br> 2-u joint driveshaft is loose and needs replaced $560 (why it vibrates??)<br> 3-trannny fluid is old needs flushed $180 (hopes that it will help) <p> 4- OBDII shows no codes pulled per volvo dealer (they say no turbo or vaccuum/hose issues then???)<p>I asked others on volvoxc forum and no one thinks that the bevel/angle gear being bad should make it lose power/accelerate slowly and I need a second opion. <br> <B>QUESTIONS</B><I></I><br><B></B>What does happen when a 'bevel/angle gear' goes bad???<p> AND <p><B>What would cause this volvo xc to be so slow??? </B><p>Thanks!!!!!!!!!<p>Nomar
 

·
Registered
Joined
·
63,543 Posts
Re: extremely slow accleration 2000xc at 68k (Nomar1)

This was already answered, a good bet is a hose (vacuum) leak, causing no power.<br>If the leak is not obvious, you need to "smoke test" the wagon.<br>Take it to a reputable VOLVO mechanic
 
1 - 2 of 2 Posts
Top