SwedeSpeed - Volvo Performance Forum banner

521 - 540 of 563 Posts

·
Registered
Joined
·
3,418 Posts
Discussion Starter · #521 ·
On the way to work today, I grew impatient behind a dump truck. So, full boost boogie time! WAAAAAA...POOF! Limp mode. Fudge! Pop the hood and have a look. Blew the OTE pipe out of the turbo coupler. Fortunately, I threw the tool bag in the car. Put it back together and cranked on the clamp.

Earlier in the day, I topped off the coolant and drained a few ounces of transmission fluid by removing the spin on filter. Perfect! When I got home the level was at the max hot line.

Sent from my SM-G950U using Tapatalk
 
  • Like
Reactions: Antherzoll

·
Registered
Joined
·
17,295 Posts
Hahaha boost
 

·
Registered
Joined
·
3,418 Posts
Discussion Starter · #525 ·
Partially? I needed a 30 deg coupler with a 2" outlet. All I had was a silicone one with 2.5" outlet. So, I slid my old 2" rubber coupler into it. A little shade tree, but works if you clamp it tight enough. It's only temporary until my new coupler gets here this week.

Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
931 Posts
40% higher capacity for not a huge amount of money


If the link goes to a no longer available notice just search the part number indicated
 

·
Registered
Joined
·
5,311 Posts
40% higher capacity for not a huge amount of money


If the link goes to a no longer available notice just search the part number indicated
Ok, thanks. Quite sure what I've ordered is the same size just used for $50 CAD shipped. The number of plate stacks count the same as the one in the image, unless I'm missing something.
 

·
Registered
Joined
·
3,418 Posts
Discussion Starter · #530 ·
Ok, thanks. Quite sure what I've ordered is the same size just used for $50 CAD shipped. The number of plate stacks count the same as the one in the image, unless I'm missing something.
The 8677973 is the 15 plate D5 cooler. Is there another difference?

Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
5,311 Posts
The 8677973 is the 15 plate D5 cooler. Is there another difference?

Sent from my SM-G950U using Tapatalk
I had to search through quite a few eBay listings for the best deal. It looks like 8677973 is also posted for a cooler that is the same size as the original but for diesel. What looks like the correct PN for the larger cooler is Volvo 31201912, but for some reason still gets listed as 8677973 by sellers on eBay.

Other PNs I found for Volvo 31201912 are:
Hella 8MO 376 751-791
C5850003
 

·
Registered
Joined
·
3,418 Posts
Discussion Starter · #532 · (Edited)
I had to search through quite a few eBay listings for the best deal. It looks like 8677973 is also posted for a cooler that is the same size as the original but for diesel. What looks like the correct PN for the larger cooler is Volvo 31201912, but for some reason still gets listed as 8677973 by sellers on eBay.

Other PNs I found for Volvo 31201912 are:
Hella 8MO 376 751-791
C5850003
Ahh, Volvo part number confusion (and add in some eBay chaos too)! I spent a lot of time tracking them down a few months ago. I believe that the 31201912 is still 15 plates. Maybe it superseded 8677973 (or maybe the other way around)? Mine also has the Behr C5850 number on it, along with the Volvo 8677973.
 

·
Registered
Joined
·
1,700 Posts
Yes, I assume it's still set for halogen. Can that be changed with VIDA?
No, but you can with Vdash

Sent from my Pixel 5 using Tapatalk
 

·
Registered
Joined
·
578 Posts
Did some xenon headlight issue debugging. When I turn on the lights with the engine not running, or start the engine with the lights on, the CEM shuts off the right headlight. Swapped CANBUS adapters. No change. Swapped ballasts. No change. Just have to live with it, I guess.

Bumper cover back on and under engine shield back on. Topped off the transmission fluid. Test drive time. Take it easy through the neighborhoods. No issues. Hit the main road and the low coolant warning starts flickering. Great. Make a beeline for home. Back into the garage. Pop the hood and grab a light. No obvious leaks. Thermostat must of popped fully open. Top that off in the morning. Checked the transmission fluid. A bit high. I'll have to draw out a couple of ounces once tomorrow.

Wife's car is back in the garage. She'll be happy!

Sent from my SM-G950U using Tapatalk
Which Canbus adapters did you use?
 

·
Registered
Joined
·
3,418 Posts
Discussion Starter · #535 ·
Th
Which Canbus adapters did you use?
The ones from TRS. Once the lights are on, I'm good. It's the lower voltage start up conditions causing the problem.
 

·
Registered
Joined
·
578 Posts
Th

The ones from TRS. Once the lights are on, I'm good. It's the lower voltage start up conditions causing the problem.
I think I got same issue. Tried installing HIDs in place of halogens using OEM ballasts and headlights turn on for a second then turn right back off.
 

·
Registered
Joined
·
3,418 Posts
Discussion Starter · #537 ·
I think I got same issue. Tried installing HIDs in place of halogens using OEM ballasts and headlights turn on for a second then turn right back off.
I'm wondering if a relay would fix the problem? Run through the CANBUS adapters to a relay. The relay would be connected to power. That way, any initial current surge to ignite the lights isn't seen by the CEM.

Sent from my SM-G950U using Tapatalk
 

·
Registered
Joined
·
3,418 Posts
Discussion Starter · #538 ·
Purty! Got some T-Bolt clamps to go with it.


Sent from my SM-G950U using Tapatalk
 
  • Like
Reactions: tabormeister

·
Registered
Joined
·
1,164 Posts
I had to buy a brand new OTE pipe after silicone hose and t-bolt clamp. Could not stop the air leak.
 

·
Registered
Joined
·
3,418 Posts
Discussion Starter · #540 ·
I had to buy a brand new OTE pipe after silicone hose and t-bolt clamp. Could not stop the air leak.
Did you crack it?

Sent from my SM-G950U using Tapatalk
 
521 - 540 of 563 Posts
Top