SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
1,804 Posts
Discussion Starter · #1 ·
Offical Evolve Problem Thread

Seeing that there has been quite a few issues with evolve parts i figured i would go ahead and get a thread together to join all the seperate issues together. For the record, i am a volvo technician working in a dealership in minnesota. i have installed IPD sway's, assisted in evolve sway's, eibach springs, Exhaust's, etc on R's, and other volvo's<p>Here is a list of issues i have seen with evolve parts. I highly encourage other's to add to this list with their issues and concerns. Also i would like to see if there has been any changes/modifications made to make these parts fit.<p>Evolve Sway bars:<br>1)End of sway bar hits and damages control arm.<br>2)insufficent clearance between subframe and bar. The bar will hit the subframe, and acually is making the paint come off. there is 3 places that it is hitting on the vehicle i am working with.<br>3)bushings too small - this is the cause of the other issue...but if you look at the bushing, it doesnt really do much, it is a very thin liner.<br>4)Rust. not much else to be said about that<p>Evolve 3.5in Downpipe:<br>1)where the pipe reduces, the pipe itsself hits the center driveshaft carrier plate. part of this plate had to be cut away to get it closer to fit. after that, i found the flange joint between the DP and catback to be hitting the same carrier plate, but in a different area. this area had to be cut also to allow the 2 flanges to come into good contact with eachother. <br>2)After modifying the carrier plate, there is only 1/4in of play in the exhaust before it hits the bottom of the car. Due to this, the exhaust rattles horribly and causes some bad vibration's<br>3)the welds are crap, seriously it looks like a 10yr old did them.<br>4)there is only 1/2in gap between the front of the driveshaft (where it ataches to the angle gear) i do not know if this is also causing an issue while driving or not, there is too many other noises going on.<p>Adjustable Sway bar endlinks:<br>1)threaded rod is not long enough to allow for any adjusting, canot get a neutral setting with a lowered car.<br>2)the rod and aluminum body corrode together, will not allow on car adjustments<br>3)swar bar and strut attachment points do not fit tightly. even when tightened, i belive that this is causing alot of noise on my own car.<p>Exhaust:<br>1)Same weld issues as before.<br>2)Rusting already after 5kmiles<p>Also, i have heard of the sway bars breaking in certain situations? can anyone confirm this? it would not suprise me due to the fact that the bar itsself is hollow.<p>I am by no means trying to "hate" on evolve, but these issues are major, and from what it seems, very common. We(and evolve) need to resolve these issues.<p><br>
 

·
Registered
Joined
·
82 Posts
Re: Offical Evolve Problem Thread (Helmut Ranff)

<B>Here are some links to the other on-going Evolve discussion/forums...</B><p><A HREF="http://forums.swedespeed.com/zerothread?id=55831" TARGET="_blank">http://forums.swedespeed.com/zerothread?id=55831</A><br><A HREF="http://forums.swedespeed.com/zerothread?id=55897" TARGET="_blank">http://forums.swedespeed.com/zerothread?id=55897</A><br><A HREF="http://forums.swedespeed.com/zerothread?id=55427" TARGET="_blank">http://forums.swedespeed.com/zerothread?id=55427</A><p><A HREF="http://evolvecars.com/forum/viewtopic.php?t=36" TARGET="_blank">http://evolvecars.com/forum/viewtopic.php?t=36</A> <br><A HREF="http://evolvecars.com/forum/viewforum.php?f=10" TARGET="_blank">http://evolvecars.com/forum/viewforum.php?f=10</A><p><br>
 

·
Registered
Joined
·
127 Posts
Re: Offical Evolve Problem Thread (D-Autobahn Guy)

We are currently addressing each of the issues mentioned here, thank you to everyone who is communicating with us. If anyone has any questions please contact us directly. I will post general information regarding solutions as it becomes available. Our telephone number is (626) 305-5529 or email me at [email protected]<p>Regards,
 

·
Registered
Joined
·
2,026 Posts
Re: Offical Evolve Problem Thread (khays)

My dealership commented on the high quality of Evolve's stuff. They knew who Evolve was, and were more than happy to install any Evolve parts I purchased.<p>Evolve has been very helpful with issues I have encountered so far. I have no doubt that they will address these concerns. Pick up the phone folks!<p>(this was NOT a paid advertisement <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/wink.gif" BORDER="0">)
 

·
Registered
Joined
·
431 Posts
Re: Offical Evolve Problem Thread (garbergtsi)

I have the 3.5" dp and personally have not noticed any issues with the fittment. <p>But I have had a big PIA with the tip. Had the dp and exhaust put on in Dec. First one of the clamps broke (didnt have a torch to weld it). And the tips it turns out were coming out at 3 3/4" overall height, not 3 1/2". I have the factory body kit, and that just wasnt working. Then when I did get the tip on, it was aiming up too much so it still barely cleared. Seems like noone else with the body kit has this issue. Had to use a torch to bend the hanger then re-weld the tip and pipe coming out of the muffler. I will say that Don and Keith were great to deal with. Sent me out the smaller tip ASAP when I called. Also sent me quality clamps since I couldnt get the welds done right away. <p>FWIW, I had the work done at the dealer. They were all commenting on the quality. I havent noticed any rust yet (they salt roads around here like maniacs!!), but I havent had it on a lift recently.
 

·
Registered
Joined
·
8,839 Posts
Re: Offical Evolve Problem Thread (frankhoffy)

We haven't had any issues w/ Evolve's hardware.<p>We had one exhaust piece that spilt at the weld, 24 hrs later we had a new piece.<br>
 

·
Registered
Joined
·
1,804 Posts
Discussion Starter · #8 ·
The vehicle in question was a 05 S. <br>We ended up trying another DP we had around, and it fit alot better, no longer hit the bottom of the car at the flanges, but we still found the flex pipe hitting the firewall when driving....<p>Also, i am going to try putting on the DP's on a 04 V....i will report how it goes...
 

·
Registered
Joined
·
82 Posts
Re: Offical Evolve Problem Thread (frankhoffy)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>frankhoffy</b> »</i></TD></TR><TR><TD CLASS="quote">My dealership commented on the high quality of Evolve's stuff. They knew who Evolve was, and were more than happy to install any Evolve parts I purchased.<p>Evolve has been very helpful with issues I have encountered so far. I have no doubt that they will address these concerns. Pick up the phone folks!<p>(this was NOT a paid advertisement <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/wink.gif" BORDER="0">)</TD></TR></TABLE><p>This is great news...for you. I am not a production specialist, but it sounds like there might be an issue with the different product batches they have coming in, or Volvo is just changing things enough in their vehicle designs that it is making it difficult to mod. However, if it were Volvo changing the design, I would think everyone would be complaining about any and all bolt on mods purchased. I haven’t seen that come up, YET.<p><B>And for the record</B>, I don't think anyone has said that they have not picked up the phone, and/or sent them e-mails, and/or posted to the Evolve forum. I think the common theme has been non-responsiveness. Although they seem like they might be trying to turn the corner, although personally I haven't seen any tangible results yet. Hopefully all of this will result in a bigger and better company that all of us can be proud of – oh yeah, and want to keep donating $$$ to. <br>
 

·
Registered
Joined
·
6,037 Posts
Re: Offical Evolve Problem Thread (garbergtsi)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>garbergtsi</b> »</i></TD></TR><TR><TD CLASS="quote"><br>Evolve Sway bars:<br>1)End of sway bar hits and damages control arm.<br>2)insufficent clearance between subframe and bar. The bar will hit the subframe, and acually is making the paint come off. there is 3 places that it is hitting on the vehicle i am working with.<br>3)bushings too small - this is the cause of the other issue...but if you look at the bushing, it doesnt really do much, it is a very thin liner.<br>4)Rust. not much else to be said about that<p>Evolve 3.5in Downpipe:<br>1)where the pipe reduces, the pipe itsself hits the center driveshaft carrier plate. part of this plate had to be cut away to get it closer to fit. after that, i found the flange joint between the DP and catback to be hitting the same carrier plate, but in a different area. this area had to be cut also to allow the 2 flanges to come into good contact with eachother. <br>2)After modifying the carrier plate, there is only 1/4in of play in the exhaust before it hits the bottom of the car. Due to this, the exhaust rattles horribly and causes some bad vibration's<br>3)the welds are crap, seriously it looks like a 10yr old did them.<br>4)there is only 1/2in gap between the front of the driveshaft (where it ataches to the angle gear) i do not know if this is also causing an issue while driving or not, there is too many other noises going on.<p>Exhaust:<br>1)Same weld issues as before.<br>2)Rusting already after 5kmiles<p><br></TD></TR></TABLE><p>I cannot speak for the enlinks that Evolve sold.... but....<p>There was a car at the dealership this morning that has had these parts from evolve for about 10,000 miles now. I know for a fact that this R has seen more track time than 95% of the people on this board.... needless to say if something was going to go wrong it would happen on this R.<p>Swaybars are fine. No problems whatsoever. The reason that this may me a problem, I am willing tp bet was the installation. There was NO rubbing or cutting of any kind on this R after 10K+ miles and ALOT of track time.<p>DP/Exhaust, not a bit of rust. Fitment is not the caliber it should be on the exhaust but no problems whatsoever with the DP on this guys R. The exhaust brackets need to be removed and PROPERLY fitted so the exhaust can be centered the way it should have come from Evolve.<p>Hope this helps.<p>
 

·
Registered
Joined
·
514 Posts
Re: Offical Evolve Problem Thread (R_Rated)

Frank, seems how this is an official problem thread, what's your problem? <IMG NAME="icon" SRC="http://www.vwvortex.com/zeroforum_graphics/screwy.gif" BORDER="0">
 

·
Registered
Joined
·
2,528 Posts
Re: Offical Evolve Problem Thread (KVB)

I don't think he's received his blue airbox he paid for in early November and is afraid to ask so instead of bitch he praises in a PA way <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0">
 

·
Premium Member
Joined
·
12,504 Posts
Re: Offical Evolve Problem Thread (slowrey)

I don't think that an online forum should be used as a Customer Service Dept.. Please e-mail or contact suppliers directly.<p>
 

·
Registered
Joined
·
1,659 Posts
Re: Offical Evolve Problem Thread (JimLill)

Jim, I have to respectfully dissagree. This forum informs us and others on products and services (good and bad). In this case there are product and service questions here that can have an "unbiased" opinion. That helps a ton for nebies and vet's. All of this info has helped me greatly in my realashonship with Evolve, Keith and Don. Athough it is a work in progress, things between myself and Evolve have definately improved because of these threads. Just my 2c's.
 

·
Premium Member
Joined
·
12,504 Posts
Re: Offical Evolve Problem Thread (MASH)

To clarify...........<p>I would hope everyone with an issue with any vendor calls them first before "going public" with it. I know from the past here on SS that has not been the case, and I am not referring to (just) Evolve.<p><br>
 

·
Registered
Joined
·
1,659 Posts
Re: Offical Evolve Problem Thread (JimLill)

Clear as day! <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/biggrin.gif" BORDER="0">
 

·
Registered
Joined
·
824 Posts
Re: Offical Evolve Problem Thread (garbergtsi)

I have had ZERO problems with Evolves performance mods. This includes rotors, brake-lines, swaybars and springs.<p>I have had them nearly a year as well.
 

·
Registered
Joined
·
2,026 Posts
Re: Offical Evolve Problem Thread (slowrey)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>slowrey</b> »</i></TD></TR><TR><TD CLASS="quote">I don't think he's received his blue airbox he paid for in early November and is afraid to ask so instead of bitch he praises in a PA way <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0"></TD></TR></TABLE><p>It's on its way my friend.
 

·
Registered
Joined
·
1,804 Posts
Discussion Starter · #19 ·
First of all, we have contacted evolve.<br>sorry, but "just grind away part of the sway bar" doesnt cut it.<br>How can you put on a sway bar wrong?? this is all simple stuff, that we do everyday at the dealership. I have installed other aftermarket products, and havent ran into any issues at all. I just wonder why is it that every part from evolve that i have seen has problems fitting, or runs into problems down the road?<br>
 

·
Registered
Joined
·
63,543 Posts
Re: (garbergtsi)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>garbergtsi</b> »</i></TD></TR><TR><TD CLASS="quote">First of all, we have contacted evolve.<br>sorry, but "just grind away part of the sway bar" doesnt cut it.<p></TD></TR></TABLE><br>You can't, it's designed wrong
 
1 - 20 of 22 Posts
Top