SwedeSpeed - Volvo Performance Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hi. Had the ETM replaced on my '99 V70 under the warranty late last year...been running great except for two incidents, one in Feb of this year and one yesterday.<p>In Feb, took the car in for an oil change, and part of their full "service" was checking the air filter (I watched as they did this). They removed the air filter to spray the dust out of it with a hose. I told them when opening the air filter housing to be very careful, seeing as it is connected to my precious new ETM, and I'm assuming the MAS is right down the line from it. He was careful, but then started using the air hose to force debris out of the air filter housing, which also didn't look like a good idea (it was causing a small tornado inside the housing as opposed to just blowing it out, and as there was no protection, I began to imagine dust and debris being forced into some expensive parts I don't want to replace). Anyway, he stopped and re-secured everything. The car started up fine, post-oil change, and then I ran through for my free car wash. Post wash the car was outside along the side of the building getting vaccumed and so forth, and as I walked up to it I began to have a sense of dread. It was idling, and in the same rough and chugging way that it did when the ETM first failed and went into "limp-home" mode. I got in, agitated, and the warning light was on and the throttle wasn't responding. I asked/told the "mechanic" wtf?, barely containing my anger (was about to go on a 2000 mile trip the next day). Anyway, he was almost a mute, but came out with a small yellow diagnostic device, plugged into the port, read the codes, and reset them (which ones, not sure, ones related to the ETM, I suppose). And the light went off, the car runs great, no problems. Disaster, or annoyance, avoided...I hope.<p>Yesterday on my weekly 300 mile r/t the "Check Engine" light came on. Fortunately, so far, it is still running perfectly and there have been no symptoms showing. After reading in another thread about the likelihood of the MAS failing after an ETM install, I'm wondering if this "alert" could be due to the (impending?) failure of this component. I wasn't able to tell from other posts if the warning light that might come on to indicate an MAS problem was the Check Engine light, or the one that comes on for the throttle failure. Any thoughts/knowledge on this much appreciated.<p>As for OBD 2 Code Readers, anyone here use them, and have the nerve or the skills to read and change codes on their Volvos? I've noticed that a unit like the guy at the car wash used can be had for from 35 to 350 dollars. Even if it was kept handy just to avoid "limping" to a mechanic does anyone have/use one of these...and is there a source/legend for the codes for a '99 V70 and what they mean?<p>Thanks again, Mark <p>
 
1 - 1 of 1 Posts
Top