SwedeSpeed - Volvo Performance Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi,<p>I am the owner of a 2006 V70R GT with about 5000 miles on the clock. Today I noticed when I started the car that the engine fan immediately came on and the car did not seem to go through its normal warm up cycle even though the outside temp was in the 30s. When I drove the car I noticed that the engine temp gauge was not working and that the car felt very sluggish as if the turbo was not kicking in. Would anyone have any ideas as to what is wrong? Any help or advice would be appreciated.<p>Thanks.
 

·
Registered
Joined
·
21,166 Posts
Re: Engine temp gauge not working (drk)

You may want to follow this thread since it sounds similar:<p><A HREF="http://forums.swedespeed.com/zerothread?id=55482" TARGET="_blank">http://forums.swedespeed.com/zerothread?id=55482</A>
 

·
Administrator
Joined
·
55,934 Posts
Re: Engine temp gauge not working (drk)

<br>yes - sounds like we're in the same boat. I've got 3600 miles on my '06. Drop it off at the dealer and let them fix it next week.
 

·
Registered
Joined
·
371 Posts
I had the same problem with 500 miles<p>its no big deal<p>the dealer will have to load a self healing progam into your car to fix it only takes about 15-20min. the heat sensor will somtimes go threw a strange heat saok and thats what causes it to shut down. <p>yes your car goes into a safety mode and it only running on about 1 poud of boost yea i know it sucks. your car is safe to drive. if your check engine light should come on then I wouldn't reccomend it..<p><br>Hope i helped some
 
1 - 5 of 5 Posts
Top