SwedeSpeed - Volvo Performance Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 · (Edited)
Engine noise/whine under load and while in neutral - failing alternator

Our 2017 XC90 now has 51k miles so just out of warranty. We drove from Salt Lake City to San Diego area on Saturday with no issues. Sunday night we started hearing a load whine noise while slowing down to a stop. It also happens on acceleration and if revved while in neutral. It happens with the AC on or off. I'm currently waiting at the Volvo dealership in San Diego to see if they can figure it out.

At first it sounded like bad tire noise when I was stopping but quickly realized it was engine related. I'm thinking a pulley or bearing is going bad. Maybe a belt but belts usually have more of a squealing sound from past experience. Here are a couple of videos of the noise. First one is in neutral and the next one is while driving.

Has anyone experienced this noise?


 

·
Registered
Joined
·
9 Posts
Discussion Starter · #2 ·
I updated the title for future search. The noise was the pulley on the alternator was separating from the alternator. Part approx $750 and $450 labor = $1200 repair.
 

·
Registered
Joined
·
6,923 Posts
I updated the title for future search. The noise was the pulley on the alternator was separating from the alternator. Part approx $750 and $450 labor = $1200 repair.
Ah... that is painful. Just in future you can get it replaced under free parts warranty if happens again.
 
1 - 3 of 3 Posts
Top