SwedeSpeed - Volvo Performance Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2,606 Posts
Discussion Starter · #1 ·
If i'm stopped, say at a red light and go to take off, as soon as the clutch starts to engage i'll get a pop/creak from somewhere under the front of the car. sounds like the drivers side.<p>i played around a little last night and managed to recreate the noise by forcefully turning the steering wheel to the right and stopping quickly. <p>endlinks? anything else i should check?<p><br>thinking about selling this car...and i want everything taken care of before i do.
 

·
Moderator
Joined
·
6,436 Posts
Could be that, or could be the engine mounts. <br>I know I hear a little clunk during take-off and sometimes during shifting because of my shot engine mounts; I could let know if if that disapears once i replace them (soon)
 

·
Registered
Joined
·
1,668 Posts
Endlinks will typically pop when you hit bumps. When mine were shot I couldn't make the sound starting from a stop. Over bumps it sounded like the front was going to fall off.
 

·
Registered
Joined
·
2,606 Posts
Discussion Starter · #4 ·
well, i know the rears wil lneed changing soon...so i do get some noise going over bumps. but then again, no more or less than there ever was. <p>the top engine mount and trans mount are brand new as of thanksgiving. as well as poly inserts for the strut bar. <p>what else could it be? the steering rack?? it only started recently, after the car had an angle gear replacement. it'll also do it if i let off the throttle in second and thne get back on it. none of it is consistent though, except when i yank the steering wheel hard when stopped. <p>i had the car over a highbloom auto a few days before i brought it to volvo for th eangle gear replacement and nick checked the front end, said everything was good....<p>EDIT: and it's not axle ping, xc90 bolts were the first thing i ever did.
 

·
Registered
Joined
·
3,481 Posts
Re: (TGO)

I had this as well and the axle bolts were loose. But I'm hearing it again (since I did the upper engine mount conversion to strut bar) and I know my upper engine and lower tranny mounts are shot.<p>So this could be your problem. Do the bolts first. 5 min.
 

·
Registered
Joined
·
719 Posts
if its happening when you turn the wheel i am willing to bet it is the endlinks mine was doing that and i replaced them.....do your balljoints while your in there cuz mine were shot! (both endlinks and balljoints).<p>your VR is an 04 so im sure you have high miles like me....welcome to replacing Volvo's shoddy ball joints and various bushings
 

·
Registered
Joined
·
2,606 Posts
Discussion Starter · #9 ·
ok im due for an alignment soon so i'll have them check <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0"> <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/embeer.gif" BORDER="0">
 
1 - 9 of 9 Posts
Top