SwedeSpeed - Volvo Performance Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Today I received a message on my 2001 S60 that states "Emission system service required" anyone know what that could involve? Also, is that something I would have to take to the stealership to get fixed?<p>Thank you
 

·
Registered
Joined
·
2,257 Posts
Re: Emission system (Guinea)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>Guinea</b> »</i></TD></TR><TR><TD CLASS="quote">Today I received a message on my 2001 S60 that states "Emission system service required" anyone know what that could involve? Also, is that something I would have to take to the stealership to get fixed?<br>Thank you</TD></TR></TABLE><p>Stealership, I like that. Anyhoo, someone else on here just had the same thing happen... <IMG NAME="icon" SRC="http://********************/smile/emthdown.gif" BORDER="0"> <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/frown.gif" BORDER="0">
 

·
Super Moderator
Joined
·
14,831 Posts
definitely do a search on the forum for it. there are lots of people who have seen this in the past. maybe you can try a few things before taking in it for something stupid like a gas-cap.
 

·
Registered
Joined
·
40 Posts
Re: (phuz)

I got that message 5-6 times in the past, after the last time i took it into my mechanic and they replaced a coil pack on one of the cylinders and it seems to have fixed the problem since i havn't seen that message since. It cost about me about $90 + diagnostics ($70 to hook it up to a computer is crazy!)
 

·
Super Moderator
Joined
·
14,831 Posts
the coil pack itself caused an emission code? strange.
 

·
Registered
Joined
·
4,017 Posts
Re: Emission system (Guinea)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>Guinea</b> »</i></TD></TR><TR><TD CLASS="quote">Today I received a message on my 2001 S60 that states "Emission system service required" anyone know what that could involve? Also, is that something I would have to take to the stealership to get fixed?<p>Thank you</TD></TR></TABLE><p>well it can be a lot of things for example i got that message after some 160 mph+ race, i think the O2 sensors overheated and damage due the heat and flow.<p>After i replace the sparks, O2 sensors the car runs fine again.
 
1 - 6 of 6 Posts
Top