SwedeSpeed - Volvo Performance Forum banner
1 - 20 of 32 Posts

·
Registered
Joined
·
6,415 Posts
Discussion Starter · #1 ·
For those who have been following another thread of mine I had a metal rattling noise coming from the rear I could not identify.
Today I did! It came from my Elevate rear sway-bar I installed few months ago.
I could not see it when inspecting the sway bar but I realized that the end-link threaded rod is much smaller in diameter than the Elevate sway-bar. This was causing the end link to shift when the nut would loosen just a bit.

I thought I'd share the fix I did for all those who have this Elevate setup:

Keep in mind I have vertical end-links (horizontal holes on the sway-bar)

I fixed it by machining an aluminum sleeve to fit between the end-link threaded rod and the sway bar hole.

I'll have to double check the dimension tomorrow to give you what I used but I was able to find a standard aluminum tube that just fit the sway-bar hole to which I machined the inside with a simple drill bit. I used a lay I have at my work shop but it can be done with a simple drill I believe.

Here is what I did:

- You can see the huge gap -


- Fits right over -



- pushed in -


NOW I CAN ACTUALLY FEEL THE STIFFNESS OF THE SWAY-BAR . . . LOL

Sorry for the crappy shots. I borrowed a camera that could not focus on the right thing :p
 

·
Registered
Joined
·
2,282 Posts
Very nice work!

I actually ended up making my own endlinks for the elevate sways with 12mm ends to fit in there.
 

·
Registered
Joined
·
6,415 Posts
Discussion Starter · #5 ·
stealth: I don't know!!! but agree!!!
I guess it's possible there are different end-links size out there.
 

·
Registered
Joined
·
6,415 Posts
Discussion Starter · #6 ·
Would You Machine Me Two Bronze One's - Please , but Me Bar has Been Fine hasn't moved - Checked for Movement .
Really, it's not that hard . . . I know you can do it yourself ;D
 

·
Registered
Joined
·
6,415 Posts
Discussion Starter · #8 ·
They fit our cars?
 

·
Registered
Joined
·
4,007 Posts
yeah i had this problem too when one of my blue ipd endlinks fell out because ipd forgot to send me washers when i asked for them.

 

·
Registered
Joined
·
81 Posts
strange. I've had the elevate rsb for over a year now with no problems. the connection looks fairly flush on both sides with vertical tabs but who knows, i have a 09.
 

·
Registered
Joined
·
3,256 Posts
TG what diameter pipe did you use? Mine hasn't budged (that I'm aware of) and would like to do this as a precaution.
 

·
Registered
Joined
·
6,415 Posts
Discussion Starter · #13 ·
Dam I wanted to list it.
Sorry I got swamped this week . . . if it can wait Monday I'll let you know then.
I got the material at my job's shop and I was not planning on going to the office this weekend. . .
 

·
Registered
Joined
·
3,256 Posts
Dam I wanted to list it.
Sorry I got swamped this week . . . if it can wait Monday I'll let you know then.
I got the material at my job's shop and I was not planning on going to the office this weekend. . .
Next week would be great! Thanks tg!
 

·
Registered
Joined
·
6,415 Posts
Discussion Starter · #15 · (Edited)
hey Slasher, here it is.

I used an aluminum tube that was .5" (12.7mm) in OD
The OD fit perfectly. The nice thing about the aluminum is that it'll deform to what ever imperfection on the sway bar.

The ID was .375" (9.5mm) and I re-drilled it at 0.385" (9.8mm) which fit just over the threaded End-link.
That all said, I would double check your setup.
 

·
Registered
Joined
·
3,256 Posts
thanks TG!!!!
 

·
Registered
Joined
·
3,256 Posts
hey Slasher, here it is.

I used an aluminum tube that was .5" (12.7mm) in OD
The OD fit perfectly. The nice thing about the aluminum is that it'll deform to what ever imperfection on the sway bar.

The ID was .375" (9.5mm) and I re-drilled it at 0.385" (9.8mm) which fit just over the threaded End-link.
That all said, I would double check you setup.
would a .402 ID be too big? my other option is .370 ID....
 

·
Registered
Joined
·
6,415 Posts
Discussion Starter · #19 ·
I think .402 will be fine. That's not even a 0.5mm difference and I was almost too clothe to the bolt diameter.
 
1 - 20 of 32 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top