SwedeSpeed - Volvo Performance Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
I thought I had my problems fixed, but they're back. I have narrowed it down a little though. Here's an overview: when the car does have problems it always starts with the interior lights coming on and a message pops up that says the left rear door is open. I eventually lose all the dash controls and display but before I lose the display it shows a check engine light, brake failure messages, abs light, transmission messages, etc. basically everything. It ends up losing the a/c and the car jerks badly randomly while driving like the transmission is catching. It also accelerates very slow and doesn't feel like it shifts gears. Almost like it sticks itself in 2nd or 3rd and stays there.

I had temporarily fixed these problems before by fixing the leak in the power steering reservoir. Now that the weather is hot again the problems have returned. I have visually confirmed that the fan for the ecu doesn't work. The fan itself works fine and it does have power going to it, so it seems like a ground wire might be bad. The last 2 days when the car has been having problems I've taken out the fan and cleaned the connections, the grounds closest to the fan, and around the top of the alternator with some electric parts cleaner. For some reason doing that actually fixes my problems for the day. I think my power steering is leaking somewhere again though possibly underneath the pump. Does anyone have any ideas? Could it possibly be the alternator that is having problems or does it sound like it would be because of the ecu fan? I thought it was the fan until everything seemed to be fixed besides the fan after I sprayed it off with the electric parts cleaner. Just throw out ideas for me or anything really. My best guess right now is that the power steering fluid is leaking worse because the weather is hot and possibly messing up the connections on the alternator but I have no idea honestly.
 
1 - 1 of 1 Posts
Top