SwedeSpeed - Volvo Performance Forum banner
21 - 32 of 32 Posts

·
Registered
2004 Volvo S60R M66
Joined
·
13 Posts
Discussion Starter · #21 ·
I think that you have the answer. What year is the car? The ECM needs a tune to be able to run on the higher boost pressure. I looked in my VIDA, I can not find the Volvo boost spec. Mabey someone else can post it here. I assume that the Volvo high boost cut out is 15 PSI. Are there any king of settings or adjustments to adjust the boost below 15 PSI to stop the limp mode for now? If you do the ECM tune and Volvo has to perform an ECM update, this will reset the ECM back to factory spec and erase your tune SW.
A ECM update wipes a tune?
 

·
Registered
Joined
·
870 Posts
Stock K24 yea
Tuned, Supposedly it was
So being that the car was tuned that opens up a bunch of different possibilities. What I would reccomend is that you contact the tuner and run some data logs.
If you have the flashing software you could read the ECU to file in order to save the tune. From there you can flash back to the stock file and see if the problem still exists.
It's quite possible that the tune can be causing an overboost condition which is throwing the car into limp mode.

Sent from my ECU
 

·
Registered
2004 V70R (Titanium Grey/Nord) / 2016 XC90 T6
Joined
·
302 Posts
@awd6spd any fix to this I’m in the same conundrum. Except vida is giving me signal too low. I took apart every thing to clean and check and everything is solid. I unplug the maf connector and runs fine. When it’s plugged in it sounds like it used to but then dies.
Computer Personal computer Font Line Screenshot

Automotive lighting Car Hood Automotive tire Vehicle

M
 

·
Registered
2004 V70R (Titanium Grey/Nord) / 2016 XC90 T6
Joined
·
302 Posts
I just think it’s odd that it runs better without the maf plugged in? I tried to run some parameters on vida but I’m hungry and steaks about done possibly after
 

·
Registered
Joined
·
870 Posts
If it runs better with the maf unplugged then there is either an air leak or a bad MAF. Start with smoking the system and you can also check the MAF airflow in Vida.
My primary guess is air leak.

Sent from my ECU
 

·
Registered
2004 Volvo S60R M66
Joined
·
13 Posts
Discussion Starter · #26 ·
I just think it’s odd that it runs better without the maf plugged in? I tried to run some parameters on vida but I’m hungry and steaks about done possibly after
If you manage to run some parameters your MAF should idle at 12-14kg/h at operating temp, if it's higher you may have an air leak, or bad MAF
 

·
Registered
2004 V70R (Titanium Grey/Nord) / 2016 XC90 T6
Joined
·
302 Posts
The thing that sucks is I can’t keep the car running with the maf plugged in. There’s an air leak I just don’t know where I double checked everything. Guess somewhere maybe hidden near the tb.
 

·
Registered
2004 Volvo S60R M66
Joined
·
13 Posts
Discussion Starter · #29 ·
Also vida pulled this … because I pulled sensor too low… would that mean my air leak is not between turbo and tb? View attachment 157003
Same code im getting except I have fixed every little air leak on the car, my recommendation is to smoke test it and just keep fault tracing new leaks. B/c you may fix a leak and a new one will arise further. Also if you have aluminum OTE pipe check the O-Ring that sits at the end of the pipe going in to the Inlet of the turbo. If it has a crack or if its try rotted, replace it.
The O-Ring part number is-983891
 

·
Registered
2004 V70R (Titanium Grey/Nord) / 2016 XC90 T6
Joined
·
302 Posts
Yeah checked the pipe. I don’t know how I missed this when I had the air box out yesterday. Went to clean the bps and look what I see…..
Motor vehicle Automotive tire Automotive exterior Automotive fuel system Hood




Volvos can be difficult sometimes. But damn it Ben think simple… right in front of my eyes for 3 days. Oh well…. Lessened learned. She got a cleaning at least
 

·
Registered
2004 Volvo S60R M66
Joined
·
13 Posts
Discussion Starter · #31 ·
Yeah checked the pipe. I don’t know how I missed this when I had the air box out yesterday. Went to clean the bps and look what I see….. View attachment 157019



Volvos can be difficult sometimes. But damn it Ben think simple… right in front of my eyes for 3 days. Oh well…. Lessened learned. She got a cleaning at least
Happens to the best of us man, had a huge crack at the intercooler right by the bypass sensor and I never saw it, sometimes we all overthink.
 

·
Registered
2004 V70R (Titanium Grey/Nord) / 2016 XC90 T6
Joined
·
302 Posts
When I pulled the air box I said, “why’s there oily residue on it?” I summed it up as I haven’t cleaned the bay since last year and was waiting for the pollen to be done. Now I know why. But she’s good now! I’ll have a little add retighten hoses to the list of every other oil change. That wasn’t the only lose one…
 
21 - 32 of 32 Posts
Top