SwedeSpeed - Volvo Performance Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi fellow Volvo members, i have a 2007 C30 with a 2.0l (B4204S3) petrol engine with 199xxx km on the clock. I have a new block fitted roughly about 3000km ago from agents and I've noticed something that has started a week ago. I had the block replaced because the vehicle was taking and volvo couldn't supply rings and bearings so I just took the plunge and fitted a complete sub assembly, new oil pump and water pump. About a week ago I noticed the coolant level was low (below the mix mark), so I topped it up and continued to use the vehicle. Now when i check the bottle after a drive the bottle is empty with no signs of any leaks. I've been topping up the coolant level on a daily basis now with about +-500ml at a time. The sub assembly was fitted about a month ago but this problem only started a week ago. I have had the radiator (Aftermarket) and expansion bottle (agents) replaced about a year ago and i have replaced the cap today with the same outcome. The vehicle is not smoking, not misfiring and not even overheating. It will warm up and the gauge will stay at the halfway mark and even the fan is working as it should. Any assistance will be highly greatful.
 

·
Registered
Joined
·
92 Posts
check the oil is any coolant in it? also, when you replaced the engine and did the coolant flush, did you also turn the heater on and flush it?
it could be air trapped in the system just keep driving it for now but keep an eye on it at all times until you need to stop adding coolant
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Thank you for your post...well had time to do some work on the car...it is the head gasket, was hoping it was something smaller but it is what it is
 
1 - 3 of 3 Posts
Top