SwedeSpeed - Volvo Performance Forum banner
1 - 10 of 10 Posts

·
Banned
Joined
·
556 Posts
Discussion Starter · #1 ·
I want to add some fluid, or at least check it. IIRC, I have an Aisin Warner 4-speed that uses Dexron III, and Maxlife ATF is fine?

Thanks!

2000 V70 XC AWD< and idk if I have the 2.3 or th 2.4L Turbo 5 (non-T5.)
 

·
Registered
Joined
·
3,788 Posts
Yellow, down a bit, towards the front, drivers side (if you have a LHD car). You should see it. It's on the side of the engine a bit, where the tranny meets up, battery side.

Hope that helps.
 

·
Banned
Joined
·
556 Posts
Discussion Starter · #4 ·
Ok! I found the dipstick!

And now I have another problem: It is STUCK!!!! :(
 

·
Registered
Joined
·
2,238 Posts
Use vise grips to clamp the base of it, and rotate it to break the seal. These are a BEAR. You'll need to clean out the top of the tube and oil the o-ring on the stick to get it to move freely again.

Once you've cracked the seal and spun it a few times, yank on it with the vise grips. It will fight you.

You have the 2.4 LPT motor. Technically a Turbo-5, but not the "T5" designation the high pressure turbo 2.3L engines got.
 

·
Registered
Joined
·
808 Posts
Are you sure it's stuck? There is a metal spring clip that holds it in place.
 

·
Banned
Joined
·
556 Posts
Discussion Starter · #7 ·
Well... I have rotated it a few times, but I fear the thing will come straight off (yellow tab) if I pull too hard.

Based on what I now know, it almost seems like I am supposed to!

I can rotate the base, it is just hard to pull from it. My concern is that if i pull full-force on the tab, that it will break. is this a real concern? Thanks!
 

·
Registered
Joined
·
2,238 Posts
Are you sure it's stuck? There is a metal spring clip that holds it in place.
Not on any 98-00 that I've seen

Clamp on to the bottom of the dipstick so you don't rip the handle off. It's awful. Maybe spraying some penetrating lube into the joint where the stick meets the tube might help too.
 

·
Registered
Joined
·
116 Posts
I have a 2000R and there was a clamp on mine. It was a little bastard and almost sliced my finger. That is my guess as to why you can rotate it but can't pull it.
 

·
Registered
Joined
·
808 Posts
Maybe the spring clamp is only on the 5 speeds and not the 4 speeds?
 
1 - 10 of 10 Posts
Top