SwedeSpeed - Volvo Performance Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
533 Posts
Discussion Starter · #1 ·
I replaced trans mount this morning and noticed oil on. The cover..after removing covering saw a box that is sopping wet..noticed pcv post here and wondering if I have an issue.. Have 2005 s60..2.5t
 

·
Registered
Joined
·
856 Posts
sounds like you are in dire need of a complete pcv service. That so called box is sometimes refered to as the oil trap and is an integral part of the pcv system. If neglected, you will blow out seals like cam and rear main seals. It is expensive to have a dealer or shop to the service. You can do a more comprehensive service yourself if ya have tools and patience.
Complete kits are available at places like FCP and IPD. DO NOT DRIVE THIS CAR until it is corrected! If you do the job, you will save yourself a ****load of money and be able to properly do a lot more part cleaning that you can expect to get if ya let somebody else do it. For example,I seriously doubt that "most shops and dealerships" would address the PTC
nipple cleaning that is essential to the proper way of doing the service. I did this service on my 07 S60 with 94K on it this past August when it was hotter than hell here in NJ. I can tell ya now that I don't care what the service interval says about being due at 105K. My car needed it then and I am glad that I did it. And, my car has used Castrol Edge synth since it was new while doing oil changes every 4K. If ya care about it, address it now!
 

·
Registered
Joined
·
533 Posts
Discussion Starter · #4 ·
Thanx..I run Mobil 1 for info,truthfully I wouldn't run castrol in anything ,I imagine I do have to service pcv system ..don't have cash as I'm poor, to buy the parts
 

·
Registered
Joined
·
533 Posts
Discussion Starter · #6 ·
Didn't get a ggod look ,is by the tranny mount which my mechanic installed..did the glove test and no result,am no really losing oil either..could it be the vent feed from intake split or something?
 
1 - 6 of 6 Posts
Top