SwedeSpeed - Volvo Performance Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Could use some help with this one... <p>My 1984 240 DL Wagon was running extremely well until I tried to start it this morning and it wouldn't fire. It was turning over fairly well (until I killed the battery), but does not sound like it is getting gas. It has brand new plugs, so I assume it is sparking. I am new to the strange and confusing world of EFI, should I start there? Do Fuel Injection systems just die that quickly? Fuel Pump? Any body know any quick tests I could run to narrow this down?<br>Thanks,<br>Matt<br>***SOLVED!*** Here's the deal: <p>The no-start situation was due to a lack of fuel caused by a faulty fuel pump relay. After switching the relay, it fired right up. Apparently, this is a common problem - the combination of heat and vibration make these things malfunction all the time. My source (George Dill, Moderator - see his post below) tells me 240 owners often carry an extra relay with them for just such a situation. A good idea, and I second this recomendation to all 240 owners. A cheap and easy fix. Thanks all for your help. <p>Matt <BR><BR>
<i>Modified by mdhughes at 10:16 PM 6-12-2006</i>
 

·
Registered
Joined
·
1,579 Posts
Re: Darn thing just stopped starting! (mdhughes)

I had this happen my '86. The fuel pump just quit. You should be able to hear it.
 

·
Premium Member
Joined
·
19,953 Posts
Re: Darn thing just stopped starting! (ACD)

Welcome to Swedespeed, Matthew.<p>Most 240 owners carry a spare fuel pump relay just for this reason.<p>Scroll down on this for your application.<p>George Dill<p><A HREF="http://www.vlvworld.com/200/Section_2_5.htm" TARGET="_blank">http://www.vlvworld.com/200/Section_2_5.htm</A><p>
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Re: Darn thing just stopped starting! (gdill2)

Thanks, George. I like your relay theory, and have ordered and on the way. Will keep you posted, and thanks for the link.
 
1 - 4 of 4 Posts
Top