SwedeSpeed - Volvo Performance Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
286 Posts
Discussion Starter #1
<br> Got a new glitch that just turned dangerous. The light switch that controls whether you are running with no lights, parking lights, and normal night driving lights is messed up. When I go all the way clockwise to normal night driving settings, the headlights will go on but the tails will go out (only when I hit the brakes do they light up) and the internal lights will shutoff (instrument panal etc.). For a couple days I've found a spot I could get it to stick half way between the parking lights and night driving lights and it would work just fine. Well tonight that wasn't even working, so I found that if I just put pressure on the knob, all the lights would be on like normal, needless to say a half hour of that got annoying with one hand on the wheel and one hand on the knob. If I let go, the instrument panal lights and tails shut off and I'm left with only headlights and brake lights, but only when I brake. Just wondering if there's a simple remedy I could try, or if anybody has had this electrical problem. Any help will be greatly appreciated, thanks.
 

·
Registered
Joined
·
6,888 Posts
Re: damn light switch (biggerhurt38)

Have you checked the fuses? Maybe there might be a loose connection in the switch. You might want to check that out as well.
 

·
Registered
Joined
·
286 Posts
Discussion Starter #3
Re: damn light switch (mike_c70)

seems to be the second of the two problems, the fuses associated with the instrument panel are good, it's gotta be a loose connection just behind the switch, I'm debating whether or not to go in there myself and try fixing it.
 

·
Registered
Joined
·
2,332 Posts
Re: damn light switch (biggerhurt38)

<BLOCKQUOTE>quote:<HR>seems to be the second of the two problems, the fuses associated with the instrument panel are good, it's gotta be a loose connection just behind the switch, I'm debating whether or not to go in there myself and try fixing it. <HR></BLOCKQUOTE><p>it might be pretty difficult to get in there. if you can, im sure its just a little swtich problem. thats what it sounds like to me. your lights are working fine, but that know must have a loose wire/connection problem.<p>Good LUck
 
1 - 4 of 4 Posts
Top