SwedeSpeed - Volvo Performance Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 · (Edited)
(RESOLVED) Current Speed Display (2016 V60 - Polestar)

Just recently, the digital display for my current speed disappeared. There is a big blank spot in the middle of my display. The "analog" dial still displays my current speed, but it is pretty small. I've tried going through all of the settings options to see how to get the digital display back, but I couldn't find anything. Could someone point me in the right direction to get it displayed again?

Thanks!
 

·
Registered
Joined
·
1,814 Posts
I don''t have the answer but just for troubleshooting:
If you do something to force the speed display to go up the screen in smaller font, does it come up?
I'm assuming that area of the screen is fine and it displays other information as expected, right?
 

·
Registered
Joined
·
251 Posts
You haven't managed to change the theme? Only the power theme (red/blue, depending on car) show the big text, rest is just "normal" speedometers.
 

·
Registered
Joined
·
13,510 Posts
Maybe there's a toggle hidden in the menus that you inadvertently clicked.

I did this a few months ago and mistakenly turned off the rear camera. Service advisor showed me how to undo what I did.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
You haven't managed to change the theme? Only the power theme (red/blue, depending on car) show the big text, rest is just "normal" speedometers.
I tried switching it to the Power theme, and that fixed it. No clue how I switched off it in the first place.

Thanks!
 
1 - 5 of 5 Posts
Top