SwedeSpeed - Volvo Performance Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter · #1 ·
Recently installed Evolve lowering springs + EST exhaust (plus IPD stage 2). Now when I start out in first and sometimes after shifting to second I get this creaking / moaning sound that sounds and feels like it's happening immediately below driver floor. I plan to take it to shop to see if they can figure this out but thought I'd ask if anyone has had similar experience. I searched other posts re creaking sounds but they seemed to involve only sway bars and hard steering wheel turns. Thanks.
 

·
Registered
Joined
·
4,638 Posts
Re: creaking sound and vibration after springs install (LouisvilleSlugger)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>LouisvilleSlugger</b> »</i></TD></TR><TR><TD CLASS="quote">Recently installed Evolve lowering springs + EST exhaust (plus IPD stage 2). Now when I start out in first and sometimes after shifting to second I get this creaking / moaning sound that sounds and feels like it's happening immediately below driver floor. I plan to take it to shop to see if they can figure this out but thought I'd ask if anyone has had similar experience. I searched other posts re creaking sounds but they seemed to involve only sway bars and hard steering wheel turns. Thanks.</TD></TR></TABLE><p>Try replacing your upper spring seat with this:<p><A HREF="http://www.ipdusa.com/version.asp?strPageHistory=category&numSearchStartRecord=0&strParents=74,404&P_ID=4251&CAT_ID=404&V_ID=10807" TARGET="_blank">http://www.ipdusa.com/version....10807</A>
 

·
Registered
Joined
·
1,019 Posts
Re: creaking sound and vibration after springs install (PureDrive07)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>PureDrive07</b> »</i></TD></TR><TR><TD CLASS="quote">Try replacing your upper spring seat </TD></TR></TABLE><p>+1
 

·
Registered
Joined
·
99 Posts
Discussion Starter · #5 ·
Re: creaking sound and vibration after springs install (imageomega)

Will do. Just two in front or do I need four all around?
 

·
Registered
Joined
·
3,157 Posts
Re: creaking sound and vibration after springs install (PureDrive07)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>PureDrive07</b> »</i></TD></TR><TR><TD CLASS="quote"><p>Try replacing your upper spring seat with this:<p><A HREF="http://www.ipdusa.com/version.asp?strPageHistory=category&numSearchStartRecord=0&strParents=74,404&P_ID=4251&CAT_ID=404&V_ID=10807" TARGET="_blank">http://www.ipdusa.com/version....10807</A></TD></TR></TABLE><p>"I get this creaking / moaning sound that sounds and feels like it's happening <B>immediately below</B> driver floor"<p>Is this description consistent with what you would experience with a worn spring seat? I would have expected the creaking/moaning to come from the top of the strut tower.<p>Cheers,<p>Jeff
 

·
Registered
Joined
·
99 Posts
Discussion Starter · #7 ·
Re: creaking sound and vibration after springs install (soupandspoons)

It's a fairly generalized vibration forward of the driver's seat. My description of it being below floorboard was probably off the mark. And I now understand I would need only two of the upper spring seats. Thanks.
 

·
Registered
Joined
·
14 Posts
Re: creaking sound and vibration after springs install (LouisvilleSlugger)

I had the groaning/popping noise when turning the steering wheel, especially when the car was hot. This was very easy to diagnose: just put a wrench on the top of the strut shaft and twist on a day when the car was hot. This very nice reproduced the noise.<p>I recently did a suspension upgrade - (Bilstein HD struts, IPD HD sway bar, HD end links, new spring seats and strut mounts from IPD).<p>5,000 miles later the groan/popping. On my car (2000 XC). The noise began about 3,000 miles after installing the new struts <IMG NAME="icon" SRC="http://********************/smile/emthdown.gif" BORDER="0"> <IMG NAME="icon" SRC="http://********************/smile/emthdown.gif" BORDER="0">. I've just pulled the old spring seats, and one has failed completely. I'm replacing the seats with IPD HD seats, which are indeed beefier. BTW, one of my old seats had completely failed; the other was torn (with 100,000 mi).<p>My question: <p>Once installed, there will again be a space - about 1/4" - between the top of the strut mount and the large metal washer. Did I miss something, or is this actually correct?? The space is not apparent when reassembling the struts - it'll only appear once the spring seats are fully inserted into the strut mounts (i.e., with lots of weight on them).<p>I've seen other posts that say this space is normal. If so, this means the entire force applied to the strut shaft is applied to the spring seat. No wonder these things fail!! I'm wondering if I should make some sort of washer or bumper to fill this space.<br> <br>Thanks for any insights!<br>johng
 

·
Registered
Joined
·
99 Posts
Discussion Starter · #9 ·
Installed IPD hd spring seats and that did not solve the problem. Guess I'll have to get used to it.
 

·
Registered
Joined
·
1,480 Posts
I just reread your post about your creaking/moaning and saw you replaced your spring seats. If you haven't fixed the problem yet, I suggest new endlinks.
 

·
Registered
Joined
·
621 Posts
Re: (SHIFT_S60R)

Is it a clicking sound?
 
1 - 11 of 11 Posts
Top