SwedeSpeed - Volvo Performance Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
I was curious if anyone here has much experience with bad coolant temp sensor. Yes, I did a search but was unsatisfied w/ the results. I have a 96 850 GLT sedan w/ 113k and AT.

Once the CEL lit up, I made the oh-so familiar trip down to autozone to have the OBD read. It only kicked back code "P0117" or the coolant temp sensor. Essentially, I have experienced some weird rpms after startup. Seemingly, once the selector is in or below neutral, the engine rpm drops to ~500 or 600 and feels like it's about to stall out. Jamming the gas in an attempt to save it has little effect. The first time this happened the words "limp mode" poped into my head but I have no idea if this is the case. This near stall lasts for 10-20 seconds and then the car runs normally.

Do you think this condition will damage the engine? I think the problem could be very dangerous if I lossed power in traffic.
 

·
Registered
Joined
·
1,137 Posts
Re: coolant temp sensor (rreddick87)

Quote, originally posted by rreddick87 »
I was curious if anyone here has much experience with bad coolant temp sensor. Yes, I did a search but was unsatisfied w/ the results. I have a 96 850 GLT sedan w/ 113k and AT.

Once the CEL lit up, I made the oh-so familiar trip down to autozone to have the OBD read. It only kicked back code "P0117" or the coolant temp sensor. Essentially, I have experienced some weird rpms after startup. Seemingly, once the selector is in or below neutral, the engine rpm drops to ~500 or 600 and feels like it's about to stall out. Jamming the gas in an attempt to save it has little effect. The first time this happened the words "limp mode" poped into my head but I have no idea if this is the case. This near stall lasts for 10-20 seconds and then the car runs normally.

Do you think this condition will damage the engine? I think the problem could be very dangerous if I lossed power in traffic.

We do them all the time here at the dealer. Not uncommon. Its a dual wire
sensor. One for the gauge and one for injection. The Volvo code is ECM 123
Good time to replace the T-Stat also(Coolant Flush).
Your symptoms lead right to the temp sensor.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #3 ·
Thanks, 854T5

I have just now found a place that will do it for a reasonable price (thank God!).

Appreciate your insight -RR
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #5 ·
Re: (robert213)

I would but the padres probably wouldnt be too excited about it--
I guess they want to spend more of their money?
 

·
Registered
Joined
·
1,137 Posts
Re: (rreddick87)

Quote, originally posted by rreddick87 »
Thanks, 854T5

I have just now found a place that will do it for a reasonable price (thank God!).

Appreciate your insight -RR
http://********************/smile/emthup.gif
 
1 - 6 of 6 Posts
Top