SwedeSpeed - Volvo Performance Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi. I recently picked up a 2016 XC90. Loving it so far!

2 questions:

1. Today I started the car. The tablet screen didn't come on. Had a message that park assist was disabled. It drove ok. No clicking sound on directionals. No climate control. Then after about a mile, everything kicked on. Any ideas?

2. How the hell do I connect to Internet to download apps? Tried my home wifi while parked in driveway. Tried Bluetooth phone connected and toggled on Internet. Just says service not available. Any tips? Is there a pandora app via Sensus (not CarPlay)?

Thanks guys!!!
 

·
Registered
Joined
·
361 Posts
#2 sounds like a visit or call to your dealer rep. My dealer has started "New XC90 owner seminars" to go over all the tricks & flips. I'm going for a refresher...and I know I will learn something new.
#1 sounds more serious. If it continues, a service dept diagnostic seems in order.
 

·
Registered
Joined
·
1,006 Posts
2. How the hell do I connect to Internet to download apps? Tried my home wifi while parked in driveway. Tried Bluetooth phone connected and toggled on Internet. Just says service not available. Any tips?
Assuming you are in the US - you should have an AT&T wireless Internet modem and SIM setup. If you go into settings and then connections - you can find the menu options for the car's integral Internet connection. See if it is enabled - check to see what carrier it is connected to. On the top of the display you should see I think an icon that looks like a SIM car with signal strength bars next to it. If you can get that working - you should be easily able to download apps. (If it doesn't work - I'd suggest checking with the dealer, as I don't know any way through the interface we have of finding out the billing phone number, ICCID SIM card number, etc. -- this is all taken care of by Volvo.)

I also have a MiFi device (Verizon Wireless LTE access point) - one of these days I'll see if the car can connect to that (certainly has better coverage and speed than the AT&T 3G connection).
 

·
Registered
Joined
·
96 Posts
Another 2 possibilities to consider regarding the WiFi connectivity issue:

1 - Make sure your WiFi router's working correctly and has the latest firmware. I know my router gets into some condition where it shows the SSID OK, but after trying to connect with the password/key, it just does nothing. Once I reset the router, the XC90 would connect just fine. A firmware update for my router corrected most of those stability issues - it just seems that the XC90 is particularly good at exposing the problems.

2 - If you didn't see your SSID and you know your router's working OK, I would suspect a possible antenna connection problem. My XC90 sees at least 12 SSID's in my neighborhood when sitting in the driveway, so I know the WiFi is capable of working well (much better than my wife's XC60, I might add).
 

·
Registered
Joined
·
426 Posts
Hi. I recently picked up a 2016 XC90. Loving it so far!

2 questions:

1. Today I started the car. The tablet screen didn't come on. Had a message that park assist was disabled. It drove ok. No clicking sound on directionals. No climate control. Then after about a mile, everything kicked on. Any ideas?
Battery so low that the car disabled features to save power? I've had it once and the more the battery loaded, the more the car gave me back functions...
 

·
Registered
Joined
·
398 Posts
Hi. I recently picked up a 2016 XC90. Loving it so far!

2 questions:

1. Today I started the car. The tablet screen didn't come on. Had a message that park assist was disabled. It drove ok. No clicking sound on directionals. No climate control. Then after about a mile, everything kicked on. Any ideas?

2. How the hell do I connect to Internet to download apps? Tried my home wifi while parked in driveway. Tried Bluetooth phone connected and toggled on Internet. Just says service not available. Any tips? Is there a pandora app via Sensus (not CarPlay)?

Thanks guys!!!
Hello JoeXC90

There are a few items to check here:

(1) Under "settings" "system" "remote update service" check that the auto software update is ticked.
(2) under "communication" then "WiFi" select the WiFi hotspot. It must be minimum "WPA2 AES". Will not do " 802.1x" - you can use your phone as a WiFi hotspot as well.
(3) make sure you have the engine running
(4) go into remote updates. It should connect the service. If not go through some of the options and it should start syncing and then you get the screen with the software applications that can be loaded or updated
(5) click on software to update.

This is where I have a problem with updates. It starts and then just pauses. Volvo Service dept tell me it should update. I also have the updated software installed during January 2016. There is a ticket open with Volvo. I date say I need to head back in to get the software loaded by the dealer.

Regards

The screen you should get with software go be downloaded. Not the top left of the screen I have WiFi access running.





Sent from my Nexus 6 using Tapatalk
 

·
Registered
Joined
·
2 Posts
Internet

Hi. I recently picked up a 2016 XC90. Loving it so far!

2 questions:

1. Today I started the car. The tablet screen didn't come on. Had a message that park assist was disabled. It drove ok. No clicking sound on directionals. No climate control. Then after about a mile, everything kicked on. Any ideas?

2. How the hell do I connect to Internet to download apps? Tried my home wifi while parked in driveway. Tried Bluetooth phone connected and toggled on Internet. Just says service not available. Any tips? Is there a pandora app via Sensus (not CarPlay)?

Thanks guys!!!
Regarding the internet, the only way I could make it work was by using the Hotspot from my iPhone using Bluetooth. I tried to connect to my house Wifi and the car never found the network.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
Thanks guys. I eventually got the internet working (#2). As for the freak incident of touch screen, etc not working (#1)... It looks like a one time incident. Maybe someone's suggestion about a low battery was what caused it. Dunno.
 
1 - 9 of 9 Posts
Top