SwedeSpeed - Volvo Performance Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
146 Posts
Discussion Starter · #1 ·
Check engine light came on and was the p0300, no others were found.

Prior to this, I noticed a few times when starting up, after the initial high rev, it would settle down lower than normal, which I think is around 800 rpm, but was fine once driven. Last night, it did this and was a little rougher of a stumbling, and the cel light went on. I went to advance auto and they found one code.

The only issue I know is the pcv hose from the top of the motor to the breather box below the intake manifold has cracks and needs to be replaced, it's falling apart in some places but I don't think it would be this. I did order a new hose though.

Any thoughts? It looks like this code tends to occur with others. Code was cleared and it's running fine now.
 

·
Registered
Joined
·
2,621 Posts
Vacuum leaks of any sort can cause misfires so I would definitely address the known first. Then you may be able to isolate whether its a coil going bad or need of spark plug change, oil separator plugged, faulty mass airflow meter.
 

·
Registered
Joined
·
146 Posts
Discussion Starter · #3 ·
I got the pcv hose, but haven't installed yet. Looks like no room, I don't want to remove the intake manifold. I have done that before.
 

·
Registered
Joined
·
146 Posts
Discussion Starter · #4 ·
Life is strange. Exactly one year later to the day, my car pulls thhe P0300 code again. I never fixed the pcv hose either. The only thing I will note is that today we had a lot of rain, and I drove through some pretty deep puddles. I will check the plugs over the weekend and clean the maf/ throttle body.
 
1 - 4 of 4 Posts
Top