SwedeSpeed - Volvo Performance Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
In a previous thread I was asking if my clutch, master/slave cylinder or something else was causing my issues shifting into gear. I haven't dealt with the car yet, as I've been out of town. I go to start it up just to run it, I depress the clutch and turn the key. Starts right up and this falls on the floor mat.



Now the car shifts easily into every gear! I'm thinking WTF?!?! I do some research and find out it's the bracket holding the helper spring to the clutch pedal.



Was this possibly my issue or just an unrelated coincidence? It explains why the clutch didn't fully return after depressing it the last time i drove. But now it does return without the spring and shift smoothly.

What the hell is going on????? TIA!
 

·
Registered
Joined
·
38 Posts
Question: did your clutch assembly creak like an old wooden boat when you pressed it for a period of time before this hit the floor?

Sent from my SM-G900T using Tapatalk
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #4 ·
It did have a creak at times. Not terribly loud,but it did and maybe still does creak.

Your thoughts?

Sent from my SM-N910V using Tapatalk
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #6 ·
so I looked under the dash at the clutch pedal. Found the rest of the spring assembly sitting on top of the rod.


Guess I'll be ordering up the parts to replace it all. Seemed to work just fine without it, no harder or easier, maybe because it's been broke for some time! But without it binding up anything, it's working fine again.
 

·
Registered
Joined
·
38 Posts
It did have a creak at times. Not terribly loud,but it did and maybe still does creak.

Your thoughts?

Sent from my SM-N910V using Tapatalk
Mine creaks when the temperature is +70F, don't know why. Lubricant works only for a few days. I have read on forums that when the spring falls out like yours, the clutch is quiet and had a better feel. I am not sure if other people replaced their springs... or if we can run without them.

Sent from my SM-G900T using Tapatalk
 
1 - 7 of 7 Posts
Top