SwedeSpeed - Volvo Performance Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
09 C30 6spd, lowered on eibach. So like the description says, after i lowered my car a few months ago, i found ive been hearing a clicking noise while turning at slow speeds. originally it didnt bother me and i thought it would go away... i was wrong :p maybe 3k miles later i replaced the front sway end links (becuase mine were looking rough and i thought that might be it). Nope. on C30 world, im getting back people say they think its my CV joints or a tear in the boot. i plan to get elavates engine mount as i hear (minus the performance part), it takes weight off of the joints. as for the cv's, im about 90% sure thats it. But bc of my "mods" (says volvo of annapolis) its going to be $125 minimum to diagnose the problem and then they'll want to put volvo oem parts in that'll be 3X more then aftermarket. any help at all is appreciated,

orrr if anyone knows a volvo guy/dealership in or around MD that wont screw me over when i can basically tell them what the problem is, i just need a second opinion. im going to take pics later and put up and maybe a video as well with a youtube link so everyone can hear the noise. Again any/all help is welcomed :)
 

·
Registered
Joined
·
3,126 Posts
It could be worn CV joints.
 

·
Registered
Joined
·
3,126 Posts
Usually it's just normal wear and tear ... unless you're in the habit of hitting solid things. ;)
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #5 ·
volvo of annapolis told me it was a switch that they replaced and im good. leaving the parking lot i gave it some and BOOM, there it is again. I called them to tell them and they said they cant do anything else for me... horrible people there. Suppose to be under warranty.... my asss
 

·
Registered
Joined
·
3,126 Posts
1 - 6 of 6 Posts
Top