SwedeSpeed - Volvo Performance Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
129 Posts
Discussion Starter · #1 ·
Hello friends, I am experience two small issues. Car in question, 2014 XC60 T6 AWD (B6304T4) about 96k miles

1. At idle, I hear a chirp but it isnt rhythmic. I always thought its the belts that make the noise. I was hoping it isn't the alternator clutch setup. How does that work anyway? Does it engage like the AC does? Explains the deep cycle battery I suppose.

2. At WOT, or at least pretty close to WOT, I can feel a slight surging of power, but very very slight. This is my first turbo car so I dont know if this is normal. I understand that there is a boost pressure valve that recirculates back into intake plenum (pierberg right?)

I'm due for my next oil change shortly and since Ill be under the hood and removing bits ( passenger headlight for access to oil filter cap ). I know engine sounds can be hard to diagnose over the internet but anyone with this engine combo ever hear these issues?

Rob
 

·
Registered
Joined
·
459 Posts
When the chirp is sounding, open up the oil cap. If doing that silences the chirp, you have a broken membrane in the PCV Oil Trap (large black box that engine cover snaps onto). Hoping it's that simple. (I learned about this chirp on my 2013 XC70 T6).
 

·
Registered
Joined
·
129 Posts
Discussion Starter · #3 ·
When the chirp is sounding, open up the oil cap. If doing that silences the chirp, you have a broken membrane in the PCV Oil Trap (large black box that engine cover snaps onto). Hoping it's that simple. (I learned about this chirp on my 2013 XC70 T6).
Awesome.. Will try that. When I bought the SUV I did notice that elbow hose disconnected and split. I added a hose clamp to fasten it back onto the intake duct. It always looks a little bit oily but checking the oil levels it doesnt seem to drop that much after nearly 10k miles.
 
1 - 3 of 3 Posts
Top