SwedeSpeed - Volvo Performance Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
136 Posts
Discussion Starter · #1 ·
Check engine light came on last night, no message. Took to auto zone, he said there wasnt any codes coming up.... He told me to tighten the fuel cap, reset the code and good to go... Now the light is on again, still no message. The car seems to be running fine. Any ideas?
 

·
Registered
Joined
·
1,273 Posts
Maybe MAF? I'd get some MAF cleaner and start there. I can't think of anything else it'd be though, the fact that there's no codes coming up is pretty wierd! Good luck bro!!
 

·
Registered
Joined
·
1,738 Posts
The fact there is no code might just mean you need a more specific scanner to read it then the generic auto zone scanners. Try to find someone with VIDA or take it to a shop with the capabilities to read it.
 

·
Registered
Joined
·
27 Posts
I had the same issue a few weeks ago. They just read the codes with the car running and it worked for some reason. Mine was a misfire on cylinder 3 and a serial connection issue.
 

·
Registered
Joined
·
4,017 Posts
dont know if in your town but from i have seen there is some dealers that make "free scan" for your car, so better to check that before anything happens. Most of the codes can be read with a normal scanner, some others you will need vida/dice-
 

·
Registered
Joined
·
1,439 Posts
Mine did it and it ended up being P0128 which was the Coolant Below Regulating Temp.

Granted my thermostat and such is fine (I checked), it just happens sometimes.
 

·
Registered
Joined
·
4,640 Posts
Depends on the code, status of code and the type of scanner being used. More than likely it was an intermitent fault that resolved and the OBD II won't show it. VIDA will show a log of any codes, past, stored and pending.

MAF will show up in most OBD II, mine did when I left it unplugged after cleaning a few nights ago, light went out after I reconnected it but the code was still pulled with an OBD II (Foxwell).
 

·
Registered
Joined
·
1,141 Posts
You definitely want to hook it up to vida. I had no dummy light but Ive tried my brothers obdII scanner and nothing came up. But when i loaded up vida the other day there was a lot of stored faults. Like wheel sensor failure.. ccm button pressed too long .. some of the have probably occured a long time ago... but yea you will definitely want vida/dice tool. The chinese ones on ebay do work.. the newest one works fine on win7 too.
 
1 - 8 of 8 Posts
Top