SwedeSpeed - Volvo Performance Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
299 Posts
Discussion Starter · #1 ·
It happened a few times, all daytime with lots of sun light. When the car is started, the portrait display is very dark, impossible to see anything, but the dash display is normal. Happened a few times. Any one had this before?
 

·
Registered
Joined
·
33 Posts
Try putting your hand over the sensor in the front of the dash, below the windscreen. Make sure your cover it completely for a few seconds, and then remove your hand. Normally this fixes the sensor not adapting to the light. Happens in my XC60 some times as well. Must be a very minor software glitch.
 

·
Registered
Joined
·
1,200 Posts
Do you garage your XC90? Does this happen when going from a dark to light environment?
 

·
Registered
Joined
·
6,921 Posts
I saw similar when going out from my dark garage in winter morning last year. Will see if still the same next winter. :)

Sent from my Z978 using Tapatalk
 

·
Registered
Joined
·
299 Posts
Discussion Starter · #6 ·
While wearing sunglasses?
Hmm, I mentioned two displays have different brightness, the I was wearing sunglasses, then they would be the same. Anyway, I never wear sun glasses. So this is NOT the issue.
 

·
Registered
Joined
·
299 Posts
Discussion Starter · #7 ·
Try putting your hand over the sensor in the front of the dash, below the windscreen. Make sure your cover it completely for a few seconds, and then remove your hand. Normally this fixes the sensor not adapting to the light. Happens in my XC60 some times as well. Must be a very minor software glitch.
When this happened, I wasn't under any bridge or anything, if it is sensor issue, then both display should have the same issue.
 

·
Registered
Joined
·
299 Posts
Discussion Starter · #8 ·
Do you garage your XC90? Does this happen when going from a dark to light environment?
I park in garage, yes sometimes when I enter garage both displays go dark, but still readable. They go together, eight all dark or all bright, never one bright and one dark
 

·
Registered
Joined
·
1,504 Posts
Hmm, I mentioned two displays have different brightness, the I was wearing sunglasses, then they would be the same. Anyway, I never wear sun glasses. So this is NOT the issue.
Since the angle at which the driver looks at the instrument cluster is quite different from the
angle at which he or she looks at the center screen, it is not unimaginable that the view would
be affected in a different way when wearing polarized (sun)glasses.
Please forgive me for trying to be of help, it will NOT happen again.
 

·
Registered
Joined
·
174 Posts
It happened a few times, all daytime with lots of sun light. When the car is started, the portrait display is very dark, impossible to see anything, but the dash display is normal. Happened a few times. Any one had this before?
Yea, had this happen once or twice when starting the car in a dark place (like a garage) then quickly heading out. Not frequently, but maybe two to three times? Bit annoying. If it was for a longer drive, I'd prolly stop, turn the car off, and turn it all back on again.
 

·
Registered
Joined
·
42 Posts
This has happened quite frequently on my 2017 XC90. I was able to get it to happen at the dealer with a tech in the car. The first time they replaced the Sensus screen. When it kept happening they replaced the twilight sensor. That took care of it for over a year but in the past 3-4 months it has happened a couple times a week. When it does it has been when I started my car in a garage and then pulled outside. Except for once when I went in a long tunnel and when I came out of the tunnel it didn’t return to daylight mode. The only way I can fix it is to turn the car off, open the door and restart the car. Sometimes driving under an underpass will trip it too. It’s very frustrating.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,200 Posts
I park in garage, yes sometimes when I enter garage both displays go dark, but still readable. They go together, eight all dark or all bright, never one bright and one dark
Could be an ambient light sensor fault.
 

·
Registered
Joined
·
317 Posts
Yea, had this happen once or twice when starting the car in a dark place (like a garage) then quickly heading out. Not frequently, but maybe two to three times? Bit annoying. If it was for a longer drive, I'd prolly stop, turn the car off, and turn it all back on again.
Exact same thing happened to me, but only once. I was parked in a dark parking garage and when I pulled out, the main display was dark and would not go back to normal brightness until I restarted the car. Very weird.
 

·
Registered
Joined
·
299 Posts
Discussion Starter · #15 ·
Exact same thing happened to me, but only once. I was parked in a dark parking garage and when I pulled out, the main display was dark and would not go back to normal brightness until I restarted the car. Very weird.
Had my service yesterday, mentioned this problem, they did a total software upgrade. will wait and see
 
1 - 15 of 15 Posts
Top