SwedeSpeed - Volvo Performance Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
181 Posts
Discussion Starter · #1 · (Edited)
I was on my way home earlier this evening and the check engine light came on. Vehicle is running perfect. Same thing happened in April and when I brought it in they said it was fine and only needed a computer system update.

Of course I’m hoping that’s what the problem is again as opposed to actually having a problem with the engine. But if they tell me it only needed a computer update again I’m going to be annoyed and dubious about the diagnosis because I just brought the vehicle in about 6 weeks ago to have the software updated because I upgraded to the iPhone 12. I knew about the charging issue from this forum which by the way I can confirm like others it gets hot as hell while charging whereas my old iPhone X didn’t when charging wirelessly on the pad with the older software. But that’s a whole other story, back on topic.

Have other 21 XC90 owners had the same problem with the CEL coming on with the vehicle running seemingly normal only to be told it just needed an update? Has there been another update since the one to fix the iPhone 12 charging issue? I just want to know in case they tell me they updated the software and give me back the vehicle with the CEL turned off.

Thank you,
Mike
Sent from my iPhone
 

·
Registered
Joined
·
8,786 Posts
Your CEL is on and you seem more concerned about curing your iPhone charging issue.

Sent from my SM-G981U1 using Tapatalk
 
  • Haha
Reactions: briank240

·
Registered
Joined
·
8,786 Posts
Not true and not helpful. But thank you for chiming in.

Sent from my iPhone
Go to dealer, get codes pulled, get car fixed.

Sent from my SM-G981U1 using Tapatalk
 

·
Registered
Joined
·
2,121 Posts
I was on my way home earlier this evening and the check engine light came on. Vehicle is running perfect. Same thing happened in April and when I brought it in they said it was fine and only needed a computer system update.

Of course I’m hoping that’s what the problem is again as opposed to actually having a problem with the engine. But if they tell me it only needed a computer update again I’m going to be annoyed and dubious about the diagnosis because I just brought the vehicle in about 6 weeks ago to have the software updated because I upgraded to the iPhone 12. I knew about the charging issue from this forum which by the way I can confirm like others it gets hot as hell while charging whereas my old iPhone X didn’t when charging wirelessly on the pad with the older software. But that’s a whole other story, back on topic.

Have other 21 XC90 owners had the same problem with the CEL coming on with the vehicle running seemingly normal only to be told it just needed an update? Has there been another update since the one to fix the iPhone 12 charging issue? I just want to know in case they tell me they updated the software and give me back the vehicle with the CEL turned off.

Having to bring my car in for this is annoying because the closest dealership to me is about a 45 minute drive. I know that’s not Volvo’s fault but still a major inconvenience just for them to tell me my CEL is coming on because of the computer system. If that is so common they probably should make a Computer Engine Light come on instead of Check Engine Light so they don’t scare the crap out of the customer.

By the way, I feel like I’ve seen an option in the Sensus where you can remotely connect with a Volvo technician to troubleshoot but I can’t find it now and don’t know if it applies to my situation. If it does please instruct me how to get help this way as it may be able to save me a half day or more of missed work.

Thank you,
Mike
Sent from my iPhone
It’d be helpful to know what codes CEL is reporting. Did they give you them last time? If CEL was on when you took it in last time there had to be a code or more they reset. Alternately you could get a code reader or go to an auto parts store to have them read it for you. If it’s a generic CEL code it’ll tell you what emissions fault was detected. If it’s a Volvo specific one you could look it up or report back. Some one here will know more about it.

On the iPhone 12 front they seem to get scorching hot charging using lightning cable too. On minetry to charge on lightning more often than wireless to keep battery wear down but a few times I’ve come back expecting it to be fully charged and instead it super hot and at a lower state of charge than before I plugged in. There’s info out in the wild about that and it’s not exclusive to wireless Volvo charging.
 

·
Registered
Joined
·
232 Posts
Not true and not helpful. But thank you for chiming in.

Sent from my iPhone
The check engine light is a high level warning that can be triggered by many different events. The cel is telling you to have the error code(s) read by someone with an obd reader who has the training to interpret them and trace down the cause. Don't spend much time trying to guess what might have triggered the cel again. Chances are both occurrences are independent.
 

·
Registered
Joined
·
348 Posts

Here is my experience with CEL. If i see this code now, I just reset it myself; or i wait a few days and it will disappear, and several months later will probably reappear again.
 

·
Registered
Joined
·
42 Posts
I had one recently which went away in 1 week, I am guessing overfilling gas based on what I read. See if it goes away.
 

·
Registered
Joined
·
42 Posts
Overfilling gas? What's that?
If you are like me and squeeze every drop in. My CEL light came on day after service last time and the tech ran through a few scenarios including this one and I had just filled gas that day and I just chose to wait and see. 7-10 days later light went away. Went to service next time and nothing on diagnostics and no CEL since.
 

·
Registered
Joined
·
89 Posts
I had that light on when I switched to a higher octane fuel.

The codes turned out to read "mixture too rich" or something to that effect.

The dealer reset the sensors and light went off. Kept filling with the same octanage fuel an no more CEL.

Did you use different octanage fuel?
 

·
Registered
Joined
·
232 Posts
I had that light on when I switched to a higher octane fuel.

The codes turned out to read "mixture too rich" or something to that effect.

The dealer reset the sensors and light went off. Kept filling with the same octanage fuel an no more CEL.

Did you use different octanage fuel?
And the sun came up the morning you changed to a different octane fuel. A coincidence is not the same as cause and effect.
 

·
Registered
Joined
·
89 Posts
A precept of science - correlation does not prove causation
No it doesn´t.

However, the CEL came one right after I changed fuel type. AND the specific code that came from the reading is exactly in accord with a different burn from a different fuel.

The electronic engine control does adjust for different fuel types depending on the sensors readings from the engine.

So, although it does not necessarily was the cause, it is indeed the most likely case.
 

·
Registered
Joined
·
7,298 Posts
No, not really.

Octane doesn't change the air/fuel ratio or fuel trim.
Doesn't the ECM adjust (delay for low Octane fuel) ignition timing based on knock sensor reading?
 
1 - 20 of 21 Posts
Top