SwedeSpeed - Volvo Performance Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
180 Posts
Discussion Starter · #1 ·
Driving down 465 today when all of the sudden my CEL came on. The car didn't seem to act funny or do anything out of the ordinary, and there is no message on the display (no Red/orange ! either).

Drove the car the remaining hour with no issues and cel light on- Have a 2 hour drive in 36hours and want to know if anyone has any leads. I have my OBD scanner at home :facepalm: so I'm sure i'll figure it out sooner than later, but wanted to see if I could get a head start.

Thanks
 

·
Registered
Joined
·
997 Posts
maybe your o2 sensor tripped the cel because of your downpipe? you could always stop at your local autozone/advanced auto and they will read it for you.
 

·
Registered
Joined
·
67 Posts
Tighten the gas cap?
 

·
Registered
Joined
·
520 Posts
I was throwing the odd CEL on the highway - typically, cruising and let of gas a bit and back on again slowly seemed to do it. Put on and extension for the O2 and that seemed to do the trick.
 

·
Registered
Joined
·
180 Posts
Discussion Starter · #6 ·
I suspected gas cap as I had filled up earlier in the day. When that was the issue typically you'd see the message on the display for fuel pressure.

I wouldn't suspect O2 sensor as I have had the downpipe on for close to 15K miles now and never had the cel thrown before for this issue.

Tightening gas cap, unplug negative battery terminal to clear (ghetto I know- but i'd like to see time frame that it/if it returns during the next drive).


Thank you All for the quick input: it is much appreciated.
 

·
Registered
Joined
·
3,157 Posts
I wouldn't suspect O2 sensor as I have had the downpipe on for close to 15K miles now and never had the cel thrown before for this issue.
I wouldn't be surprised if it was the code for low catalytic converter efficiency. From what I've seen, the cheaper 200 cell high flow cats that are used by many of the downpipe makers (Phuz, RaceS60R, etc.) seem to only be good (without a spacer to trick the system into not seeing the degraded efficiency of the cat) for about 1-2 years or 10-15k miles.
 

·
Registered
Joined
·
997 Posts
I wouldn't be surprised if it was the code for low catalytic converter efficiency. From what I've seen, the cheaper 200 cell high flow cats that are used by many of the downpipe makers (Phuz, RaceS60R, etc.) seem to only be good (without a spacer to trick the system into not seeing the degraded efficiency of the cat) for about 1-2 years or 10-15k miles.
That's what I was thinking because my magnaflow 59959 has never worked. I've been trying to get my cel to go away for months. Spacer hasn't does the trick either.
 

·
Registered
Joined
·
2,192 Posts
I used to get a random CEL when driving, it would always come on a few weeks after resetting my ECU. I just kept resetting the ECU everytime it popped up so I never knew what it was, then one time it happened in the middle of a 5 hour drive, after half an hour it turned itself off and I haven't seen it again.

In the meantime I did fix some major boost and exhaust leaks, so I'll chalk the CEL up to that.
 
1 - 9 of 9 Posts
Top