SwedeSpeed - Volvo Performance Forum banner

1 - 17 of 17 Posts

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #1 ·
The car started just fine today, but after my first stop I turned the car on and the cel was on for about 3 seconds before going away. This occured again at the second, and third stop, but when I went to turn the car on after the third stop the car started, and then stalled. I turned the car off, and then on again, and I had no problem getting back home.<p>I checked the codes and out of socket 2 I was getting the 1-2-1 code. I looked up the numbers, and it says AMM sensor signal absent or faulty. I took apart the air filter housing, and found that the hot air box was indeed closed. <p>I should also state that there no are codes from socket 6(ignition)<p> Is it possible that the AMM would cause my relatively high numbers when I went to smog the car a few weeks back-especially with the NOX? Thanks in advance!
 

·
Premium Member
Joined
·
19,953 Posts
Re: Cel Code 1-2-1 In Socket 2 (fuel Injection) Of '92 240 (1sciroccofahrer)

If the air box has been getting all pre-heat air from the exhaust manifold for some time then the mass air meter could be toast.<p>Clean up the electrical connection at the mass air meter then reinstall.<p>With the engine at warm idle disconnect this same connection.<p>If you note very litttle or no change in engine operation then the mass air meter could be faulty.<p>George Dill<p>
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #3 ·
Re: Cel Code 1-2-1 In Socket 2 (gdill2)

Thanks for the help George! I am reasonably confident that the air box, and t-stat, are in good working order-for the flap was closed when I checked it last night, and that the t-stat and mechanism were replaced last summer at the dealership in Berkeley. I will take the electrical sensor off the AMM and clean it-should I just use compressed air, or should I also spray a little brake cleaner as well?-and see what happens, as well as disconnecting the electrical connection when the car is warm and idling. I will report back my findings. Thanks again <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/wink.gif" BORDER="0"> <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0">
 

·
Premium Member
Joined
·
19,953 Posts
Re: Cel Code 1-2-1 In Socket 2 (1sciroccofahrer)

Use a soft wooden toothpick soaked in electrical parts cleaner.<p>George Dill<p>
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #5 ·
Re: Cel Code 1-2-1 In Socket 2 (gdill2)

I just picked up some Mass Air Flow Sensor Cleaner, and later this evening I am going to get to work. Hopefully this will cure the problem. If not, my Volvo dismantler has the proper AMM in stock, and will sell it to me with a lifetime guarantee for $135. Have a most splendid afternoon one and all <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0">
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #6 ·
Re: Cel Code 1-2-1 In Socket 2 (1sciroccofahrer)

I drove the car approximately ten miles this morning, returned home, turned the car off, unplugged the electrical connection to the AMM, then turned the car back on, and the car started and idled the way it did when the electrical connection was connected to the AMM. After training this morning I am off to the dismantler for a AMM-with lifetime warranty. I hope this solves the issue at hand. Have a brilliant day one and all <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0">
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #7 ·
Re: Cel Code 1-2-1 In Socket 2 (1sciroccofahrer)

Once again I got the 1-2-1 code, and the car won't start unless I put it in neutral and give it gas. Looks like I am back to the Volvo dismantler tomorrow morning to replace the AMM under warranty. The fun never stops <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0">
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #8 ·
Re: Cel Code 1-2-1 In Socket 2 (1sciroccofahrer)

I just replaced the AMM, and the car starts right up (and the CEL light goes away immeditaley), but it still sounds like the RPMs are dropping to the point where the car almost stalls before picking back up again. I am thinking that the Idle Air Control Valve needs some cleaning.<br>
 

·
Premium Member
Joined
·
19,953 Posts
Re: Cel Code 1-2-1 In Socket 2 (1sciroccofahrer)

Clear all codes then dump again.<p>Dirty throttle body?<p>Air leak(s) in the intake system?<p>Vacuum problem?<p>George Dill<p>
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #10 ·
Re: Cel Code 1-2-1 In Socket 2 (gdill2)

When I replace the flame trap this evening I will look over the issues that you enumerated George-and thank you for all the help in assisting me deal with this ongoing problem <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/wink.gif" BORDER="0"> <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0">
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #12 ·
Re: Cel Code 1-2-1 In Socket 2 (gdill2)

Thanks George! I finally found where the flame trape goes-looks as if I was looking from the wrong side of the automobile <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0"> While I was busy locating it. I noticed that the ground wire from the firewall to the valve cover looks like it has seen its better days. A trip to the parts store tomorrow is in order <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0"> Have a wonderful evening one and all <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0">
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #13 ·
Re: Cel Code 1-2-1 In Socket 2 (1sciroccofahrer)

I replaced the ground wire, as well as cleaning the IAC, and the car is running quite well-knock on wood. Now I need to deal with the cat, and the car will be good to go. Have a wonderful evening one and all <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0">
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #15 ·
Re: Cel Code 1-2-1 In Socket 2 (gdill2)

The O2 sensor was replaced last summer, and I am getting no additional codes, so I think (or should I say hope) I am ready to go. I am ordering the new cat this afternoon, and will smog it on Tuesday or Wednesday. The car seems to start up much stronger now with the new ground from the firewall to the back of the valve cover-an easy fix that cost me $2.16. Cheers <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0">
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #16 ·
Re: Cel Code 1-2-1 In Socket 2 (1sciroccofahrer)

When I had the car up on the lift Friday afternoon I came to the realization that I needed the new version of the header pipe(i.e. the one with the diamond shaped end that meets the cat), and that the old sytle donut version was useless with the new cat. The parts are being installed on Tuesday, and then on to a little drive on I-5, and finally the smog test.<p>One quick question: Intermittingly, or one start out of five, the CEL light is staying on for an additional second or two longer than the other dash lights. No codes are being stored, but I am curious as to why this might be occuring. I have checked the engine mounts, but the two are in absolutely great shape. Is there a third mount that I am missing? I know where the one is by the alternator and oil filter, and the other on the opposite side of the engine, and of course the tranny mount-has a third engine mount eluded me? <p>Have a wonderful weekend one and all <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0">
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #17 ·
Re: Cel Code 1-2-1 In Socket 2 (1sciroccofahrer)

I am going to clean the fuse holder again, and see if this helps resolve the problem. Have a splendid Sunday one and all <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0">
 
1 - 17 of 17 Posts
Top