SwedeSpeed - Volvo Performance Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
481 Posts
Discussion Starter · #1 ·
Anyone have this happen to them? I went to start up my car today and it wouldn't turn. I knew it was a battery issue because my keyless entry wouldn't work. I popped the hood and fooled with the terminal connnection, got back in the car and the started without any hesitation. Any reason why this would happen?
 

·
Registered
Joined
·
2,638 Posts
Re: Car wouldn't turn until I moved the right terminal connection. (volvos70turbo)

If you are talking about the battery terminal then you need to remove and clean the terminal and posts of your battery and re-tighten the connectors. If the terminals get loose or corroded you do not get a proper electrical connection to support the current required to start the engine. Make sure you have your radio code handy if you disconnect the battery.
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #3 ·
Re: Car wouldn't turn until I moved the right terminal connection. (defgh1)

Thanks for the tip, I'll clean the terminal posts today.
 

·
Registered
Joined
·
552 Posts
Re: Car wouldn't turn until I moved the right terminal connection. (defgh1)

<BLOCKQUOTE>quote:<HR>If you are talking about the battery terminal then you need to clean the terminal and posts of your battery and re-tighten the connectors. <HR></BLOCKQUOTE><p>Use some baking soda and water solution(1 tbl spoon/12 oz) and you may not have to remove the connections. Pour a little on each terminal and watch. It'll desolve any corrosive on contact, then tighten.
 
1 - 4 of 4 Posts
Top