SwedeSpeed - Volvo Performance Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
Hey guys, ive got a 2005 s40 t5awd and last night when returning a car i fixed, my uncle and i started hearing a ticking noise coming from the motor. We rolled the car to a stop and before we stopped, while coasting in nuetral. The motor shut off. We stopped and i saw some smoke coming from under the hood. Popped it and there was oil all over the motor. We searched around and finally saw that a plug from the rear of the camshaft was blown out! Ive done a little research and saw if the PCV is clogged. It will build too much pressure and blow a plug. I dont know where the pcv is located and havent had any luck with the internet. If someone has had a similar problem please tell me how you fixed it. And if you know where the pcv is that would be great! Im gonna get all my spark plugs out and compression test the motor and look at a few other things such as timing. What do you guys think??

Sent from my LGMS395 using Tapatalk
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #3 ·
Ok. How do i check that for cloggs or how do i clean that? Do i need a new one? Thank you!

Sent from my LGMS395 using Tapatalk
 

·
Registered
Joined
·
206 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #6 ·
Thanks everyone but after removing the head i found out it was a head gasket that blew and thats what built the pressure popping the plug out as well as blowing the seals on my turbo. Ive checked the oil filter housing and it was recently replaced. Im gonna rebuild my turbo and slap a new set of gaskets as well as timing belt kit then sending her down the road. As much as i love love love her. Shes too pricey for a 20 year old college student lol. Thanks for all the advise guys.

Sent from my LGMS395 using Tapatalk
 
1 - 6 of 6 Posts
Top