SwedeSpeed - Volvo Performance Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Just picked up a 2000 s70 SE from craigslist, original owner. No major accidents, the usual wear and tear, but there's a couple things that I found curious. Take a look.

See that gap between the bumper, side panel and light? The other side has no gap at all, seamless.

http://imageshack.us/f/51/imag0164k.jpg/



Also I know its a common problem for the fog light grilles to break, but what about the damage to the bumper that you see here?

http://imageshack.us/f/100/imag0165k.jpg/
http://imageshack.us/f/109/imag0168ee.jpg/


Where do I start? What is the issue here?
 

·
Registered
Joined
·
14,003 Posts
Hard to tell from the first picture but maybe the attachment point has sagged a little on the one side.

All I see is a slight dent in the bumper cover, if that. The grilles pop off pretty easily if the bumper is jarred at all. When I had to buy a new one I zip tied it in place so I would not lose it again.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Thanks for the reply. Yes it could be sag, I know the rear bumper on my old benz is pretty warped on one side. Here's a picture of the other side for comparison. Looks impeccable.
http://imageshack.us/f/685/imag0163as.jpg/

I see you can buy the grilles for like $15 online. I think I'll try what you mentioned with the tie wraps. I really do enjoy the ride of this car, I won't mind putting a few more bucks into it.
 

·
Registered
Joined
·
302 Posts
Either the bumper cover is not installed correctly, or the passenger side fender is pushed in. Go under the car and look up - there is a white plastic mounting bracket that the bumper cover attaches to. Make sure they are mated together.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Either the bumper cover is not installed correctly, or the passenger side fender is pushed in. Go under the car and look up - there is a white plastic mounting bracket that the bumper cover attaches to. Make sure they are mated together.
I didn't think it was the side panel at first but it would make sense. The owner said his son was only in 1 fender bender but it didn't do any damage, maybe this is what he was talking about. It wouldn't make sense that it was installed incorrectly since its probably from the factory, and if it was installed incorrectly and they did replace it, then they obviously missed a spot. I'll examine it a little more tomorrow.
 
1 - 5 of 5 Posts
Top